version question

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

version question

David Flatley

      I am trying to build Openssh 6.7p1 on a Red Hat 5.6 x86_64 system
with Red Hat openssl-0.9.8e-31, which is the latest Red Hat openssl
version. The Openssh build checks openssl versions and requires 0.9.8f.
Is there a work around for this?
    Thanks.

David Flatley

______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]
Reply | Threaded
Open this post in threaded view
|

RE: version question

Porter, Andrew
Download OpenSSL 0.9.8f and install it somewhere it stays separate from the RHEL system package, say /opt/openssl098f. Building it would be something like this:

./config --prefixdir=/opt/openssl098f --openssldir=/opt/openssl098f
make
make install

Then whatever you have to do for OpenSSH to point it at that version. If the resulting OpenSSH executables need to run somewhere else (not on this build machine) you would also need to build them with the OpenSSL libraries linked statically instead of dynamically.

Andrew
________________________________________
From: [hidden email] <[hidden email]> on behalf of David Flatley <[hidden email]>
Sent: Wednesday, November 19, 2014 12:35 PM
To: [hidden email]
Subject: version question

      I am trying to build Openssh 6.7p1 on a Red Hat 5.6 x86_64 system
with Red Hat openssl-0.9.8e-31, which is the latest Red Hat openssl
version. The Openssh build checks openssl versions and requires 0.9.8f.
Is there a work around for this?
    Thanks.

David Flatley

______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]
Reply | Threaded
Open this post in threaded view
|

RE: version question

Scott Neugroschl-2
In reply to this post by David Flatley
Should probably be asked on the OpenSSH mailing lists.  My guess is that you will need to install a newer version of OpenSSL.

-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of David Flatley
Sent: Wednesday, November 19, 2014 12:35 PM
To: [hidden email]
Subject: version question


      I am trying to build Openssh 6.7p1 on a Red Hat 5.6 x86_64 system with Red Hat openssl-0.9.8e-31, which is the latest Red Hat openssl version. The Openssh build checks openssl versions and requires 0.9.8f.
Is there a work around for this?
    Thanks.

David Flatley

______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]