undefined reference errors, e.g. to `ERR_load_crypto_strings'

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

undefined reference errors, e.g. to `ERR_load_crypto_strings'

Alexander Raiola
Dear Sirs or Madams,

I have the problem that I keep getting undefined reference errors
whenever I try to access pretty much any OpenSSL-related command. I
elaborated on my problem in the following thread:
http://stackoverflow.com/questions/27106580/undefined-reference-to-err-load-crypto-strings

Can anyone please help me?

Cheers
Alex
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]
Reply | Threaded
Open this post in threaded view
|

RE: undefined reference errors, e.g. to `ERR_load_crypto_strings'

Scott Neugroschl-2
Reverse the order of the libraries.  Use -lssl -lcrypto.


-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Alexander Raiola
Sent: Tuesday, November 25, 2014 8:34 AM
To: [hidden email]
Subject: undefined reference errors, e.g. to `ERR_load_crypto_strings'

Dear Sirs or Madams,

I have the problem that I keep getting undefined reference errors whenever I try to access pretty much any OpenSSL-related command. I elaborated on my problem in the following thread:
http://stackoverflow.com/questions/27106580/undefined-reference-to-err-load-crypto-strings

Can anyone please help me?

Cheers
Alex
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]
:��I"Ϯ��r�m���� (���Z+�K�+����1���x ��h���[�z�(���Z+� ��f�y������f���h��)z{,���
Reply | Threaded
Open this post in threaded view
|

Re: undefined reference errors, e.g. to `ERR_load_crypto_strings'

Alexander Raiola
In reply to this post by Alexander Raiola
Thanks, Scott, your solution works!

Cheers
Alex

2014-11-25 17:34 GMT+01:00, Alexander Raiola <[hidden email]>:

> Dear Sirs or Madams,
>
> I have the problem that I keep getting undefined reference errors
> whenever I try to access pretty much any OpenSSL-related command. I
> elaborated on my problem in the following thread:
> http://stackoverflow.com/questions/27106580/undefined-reference-to-err-load-crypto-strings
>
> Can anyone please help me?
>
> Cheers
> Alex
>
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]