[schulz@adi.com: 0.9.8a: DSA_generate_parameters & RSA_generate_key not in libcrypto]

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[schulz@adi.com: 0.9.8a: DSA_generate_parameters & RSA_generate_key not in libcrypto]

Lutz Jaenicke-2
Forwarded to respective mailing lists

Regards,
        Lutz
----- Forwarded message from Thomas Schulz <[hidden email]> -----

X-Original-To: [hidden email]
X-Original-To: [hidden email]
Delivered-To: [hidden email]
Date: Wed, 12 Apr 2006 14:42:27 -0400 (EDT)
From: Thomas Schulz <[hidden email]>
To: [hidden email]
Subject: 0.9.8a: DSA_generate_parameters & RSA_generate_key not in libcrypto
X-Virus-Scanned: by amavisd 0.1
X-Virus-Scanned: by amavisd 0.1

I am not sure if this is a bug or something that was never defined to work.
I tried to build openssh-4.3p2 against openssl-0.9.8a.  It died with
DSA_generate_parameters and RSA_generate_key as undefined symbols.
I tried again using openssl-0.9.7i and openssh-4.3p2 built without any
problem.  The exact error is as follows:

cc -o ssh ssh.o readconf.o clientloop.o sshtty.o  sshconnect.o sshconnect1.o sshconnect2.o -L. -Lopenbsd-compat/ -L/opt/local/lib -R/opt/local/lib -L/opt/local/lib -R/opt/local/lib -lssh -lopenbsd-compat -lresolv -lcrypto -lrt -lz -lsocket -lnsl
Undefined                       first referenced
 symbol                             in file
DSA_generate_parameters             ./libssh.a(key.o)
RSA_generate_key                    ./libssh.a(key.o)
ld: fatal: Symbol referencing errors. No output written to ssh
*** Error code 1


Tom schulz
Applied Dynamics Intl.
[hidden email]


----- End forwarded message -----

--
Lutz Jaenicke                             [hidden email]
http://www.aet.TU-Cottbus.DE/personen/jaenicke/
BTU Cottbus, Allgemeine Elektrotechnik
Universitaetsplatz 3-4, D-03044 Cottbus
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]