query regarding openssl and FIPS

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

query regarding openssl and FIPS

manju prasad
Hi

I have two queries. I am new to FIPS validation.

The first query is
1. We have a system which is using Arm Cortex-A9 on ThreadX.
If I cross compile FIPS module 2.0.16 for Threadx ( Arm Cortex-A9 ) and use openssl 1.0.2s. Can we claim that our product is FIPS compliant ?

The second query is
2. One of our client wants to use FIPS module 2.0.5 on a system which is using Arm Cortex-A9 on VxWorks 6.9. If I cross compile FIPS module 2.0.5 for VxWorks 6.9 ( Arm Cortex-A9 ) and use openssl 1.0.2s. Can we claim that our product is FIPS compliant ?

Regards
Manju