Quantcast

openssl version -a bug in 1.1.0c ?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

openssl version -a bug in 1.1.0c ?

Bill Smith
Hi,
I'm in the process of building 1.1.0c and noticed a behavior difference with "openssl version -a".  The bug is that we're not seeing all of the compiler flags on the "compiler: " line.  In the following example, we're not seeing:

-q64 -O -DB_ENDIAN -qmaxmem=16384 -qro -qroconst

in the line compiler: ...

With 1.1.0c, I see this:

aix64:117$ /vobs_prgs/tools/aix64/openssl/bin/openssl version -a
OpenSSL 1.1.0c  10 Nov 2016
built on: reproducible build, date unspecified
platform: aix64-cc
compiler: /usr/vac11/usr/vac/bin/xlc_r -DDSO_DLFCN -DHAVE_DLFCN_H -DNDEBUG -DOPENSSL_THREADS -DOPENSSL_NO_DYNAMIC_ENGINE -DOPENSSL_PIC -DOPENSSLDIR="\"/vobs_prgs/tools/aix64/openssl/ssl\"" -DENGINESDIR="\"/vobs_prgs/tools/aix64/openssl/lib/engines-1.1\""
OPENSSLDIR: "/vobs_prgs/tools/aix64/openssl/ssl"
ENGINESDIR: "/vobs_prgs/tools/aix64/openssl/lib/engines-1.1"
aix64:117$

With 1.0.1m, I see this:

aix64:117$ /vobs_prgs/src/openssl/aix64/bin/openssl version -a
OpenSSL 1.0.1m 19 Mar 2015
built on: Tue Aug 30 09:59:40 2016
platform: aix64-cc
options:  bn(64,64) rc4(ptr,char) des(idx,cisc,2,long) idea(int) blowfish(idx)
compiler: /usr/vac11/usr/vac/bin/xlc_r -I. -I.. -I../include  -DOPENSSL_THREADS -qthreaded -D_THREAD_SAFE -DDSO_DLFCN -DHAVE_DLFCN_H -q64 -O -DB_ENDIAN -qmaxmem=16384 -qro -qroconst
OPENSSLDIR: "/vobs_prgs/tools/aix64/openssl/ssl"
aix64:117$

The 1.1.0c compile line:

/usr/vac11/usr/vac/bin/xlc_r  -I. -Icrypto/include -Iinclude -DDSO_DLFCN -DHAVE_DLFCN_H -DNDEBUG -DOPENSSL_THREADS -DOPENSSL_NO_DYNAMIC_ENGINE -DOPENSSL_PIC -DOPENSSLDIR="\"/vobs_prgs/tools/aix64/openssl/ssl\"" -DENGINESDIR="\"/vobs_prgs/tools/aix64/openssl/lib/engines-1.1\"" -q64 -DB_ENDIAN -qmaxmem=16384 -qro -qroconst -O -qthreaded -D_THREAD_SAFE   -c -o crypto/aes/aes_cbc.o crypto/aes/aes_cbc.c

The 1.0.1m compile line:
/usr/vac11/usr/vac/bin/xlc_r -I.. -I../.. -I../modes -I../asn1 -I../evp -I../../include  -DOPENSSL_THREADS -qthreaded -D_THREAD_SAFE -DDSO_DLFCN -DHAVE_DLFCN_H -q64 -O -DB_ENDIAN -qmaxmem=16384 -qro -qroconst -q64  -c -o aes_cbc.o aes_cbc.c


The configure command line is:

   /scratch/bsmith/perl/install/aix64/bin/perl /vobs_prgs/tools/aix64/openssl/build/Configure --prefix=/vobs_prgs/tools/aix64/openssl enable-weak-ssl-ciphers enable-rc4 enable-deprecated no-shared no-asm aix64-cc; \

Configuring for aix64-cc
CC            =/usr/vac11/usr/vac/bin/xlc_r
CFLAG         =-q64 -DB_ENDIAN -qmaxmem=16384 -qro -qroconst -O -qthreaded -D_THREAD_SAFE

I didn't see any bug reports for this in Github.  I'm seeing this behavior for HPUX and AIX.  I didn't check Linux, Solaris, or Windows.

--
openssl-users mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-users
Loading...