[openssl-users] FIPS_module_version_text()

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[openssl-users] FIPS_module_version_text()

Jason Schultz
Is this function available to call in OpenSSL 1.0.1? I'm trying to call it from my application running a FIPS capable version of OpenSSL (everything else works, turning FIPS on, etc), but I include fips.h but I get a compile error saying the function was not declared.

I did find something in the CVS repository that says it was added to 1.1.0:


I feel like I'm missing something obvious...

_______________________________________________
openssl-users mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-users
Reply | Threaded
Open this post in threaded view
|

Re: [openssl-users] FIPS_module_version_text()

Jason Schultz
I guess I didn't have the correct fips.h file in my include path when I couldn't get it to compile. But I don't think it will work for my purposes since if I install my application on another system, that entry point is not defined in libcrypto.so or libssl.so. 

Does anyone know if it's really going to be added to 1.1.0?



From: [hidden email]
To: [hidden email]
Subject: FIPS_module_version_text()
Date: Tue, 10 Mar 2015 16:01:53 +0000

Is this function available to call in OpenSSL 1.0.1? I'm trying to call it from my application running a FIPS capable version of OpenSSL (everything else works, turning FIPS on, etc), but I include fips.h but I get a compile error saying the function was not declared.

I did find something in the CVS repository that says it was added to 1.1.0:


I feel like I'm missing something obvious...

_______________________________________________
openssl-users mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-users
Reply | Threaded
Open this post in threaded view
|

Re: [openssl-users] FIPS_module_version_text()

Dr. Stephen Henson
In reply to this post by Jason Schultz
On Tue, Mar 10, 2015, Jason Schultz wrote:

> Is this function available to call in OpenSSL 1.0.1? I'm trying to call it from my application running a FIPS capable version of OpenSSL (everything else works, turning FIPS on, etc), but I include fips.h but I get a compile error saying the function was not declared.

That's odd. I just compiled OpenSSL 1.0.1 and FIPS_module_version_text was
present in libcrypto.so. Are you linking against the FIPS capable OpenSSL or
the system supplied one?

Steve.
--
Dr Stephen N. Henson. OpenSSL project core developer.
Commercial tech support now available see: http://www.openssl.org
_______________________________________________
openssl-users mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-users
Reply | Threaded
Open this post in threaded view
|

Re: [openssl-users] FIPS_module_version_text()

Jason Schultz
Hmm. I am pretty sure I was linking against the FIPS capable OpenSSL but I will double check tomorrow to make sure I did it right.

Thanks.



> On Mar 10, 2015, at 7:28 PM, Dr. Stephen Henson <[hidden email]> wrote:
>
>> On Tue, Mar 10, 2015, Jason Schultz wrote:
>>
>> Is this function available to call in OpenSSL 1.0.1? I'm trying to call it from my application running a FIPS capable version of OpenSSL (everything else works, turning FIPS on, etc), but I include fips.h but I get a compile error saying the function was not declared.
>
> That's odd. I just compiled OpenSSL 1.0.1 and FIPS_module_version_text was
> present in libcrypto.so. Are you linking against the FIPS capable OpenSSL or
> the system supplied one?
>
> Steve.
> --
> Dr Stephen N. Henson. OpenSSL project core developer.
> Commercial tech support now available see: http://www.openssl.org
> _______________________________________________
> openssl-users mailing list
> To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-users
_______________________________________________
openssl-users mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-users