[openssl.org #4701] Some OpenSSL 1.1.0 does not decode FIPS error codes

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[openssl.org #4701] Some OpenSSL 1.1.0 does not decode FIPS error codes

Rich Salz via RT
I'm working with a non-capable version of the library (I need to gt it
updated since release):

    $ openssl version
    OpenSSL 1.1.0-pre6-dev  xx XXX xxxx

Looking at a question on another site, the OP provides:

    With FIPS, compilation goes fine, but generates the following when run:

        139686960322208:error:2D0A0086:FIPS
routines:FIPS_cipher:selftest failed:fips_enc.c:336:
        139686960322208:error:2D0A0086:FIPS
routines:FIPS_cipher:selftest failed:fips_enc.c:336:

Trying to decode the error on this machine results in:

    $ openssl errstr 0x2D0A0086
    error:2D0A0086:FIPS routines:func(160):reason(134)

It seems some versions of the library don't have the necessary error
codes available to them.


--
Ticket here: http://rt.openssl.org/Ticket/Display.html?id=4701
Please log in as guest with password guest if prompted

--
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev