[openssl.org #4556] Unknown: mysterious perl(1) error during [master:8d054a5] installation process

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[openssl.org #4556] Unknown: mysterious perl(1) error during [master:8d054a5] installation process

Rich Salz via RT
On Thu Jun 02 15:50:31 2016, [hidden email] wrote:
> Hello.
>
> I have never seen something like this:
>
> Parser.c: loadable library and perl binaries are mismatched (got
> handshake key 0xdb00080, needed 0xdb80080)
>
> This is v5.24 on a Linux system, and it flawless afaik.

Are you sure that you don't have perl modules that you installed separately
with an earlier perl version? You may need to update those.

Either way, this is not an OpenSSL issue, it's a perl one. Closing this ticket.

--
Richard Levitte
[hidden email]

--
Ticket here: http://rt.openssl.org/Ticket/Display.html?id=4556
Please log in as guest with password guest if prompted

--
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
Reply | Threaded
Open this post in threaded view
|

Re: [openssl.org #4556] Unknown: mysterious perl(1) error during [master:8d054a5] installation process

Steffen Nurpmeso-2
I hope i don't "open" this one!

Richard Levitte via RT <[hidden email]> wrote:
 |On Thu Jun 02 15:50:31 2016, [hidden email] wrote:
 |> I have never seen something like this:
 |>
 |> Parser.c: loadable library and perl binaries are mismatched (got
 |> handshake key 0xdb00080, needed 0xdb80080)

I should have added that is happened during HTML creation
/ installation at first, sorry for that!

  install ./doc/ssl/SSL_set_verify_result.pod -> /home/steffen/usr/opt/.ssl-1.1.0/share/doc/openssl/html/man3/SSL_set_verify_result.html
  Parser.c: loadable library and perl binaries are mismatched (got handshake key 0xdb00080, needed 0xdb80080)
  install ./doc/ssl/SSL_shutdown.pod -> /home/steffen/usr/opt/.ssl-1.1.0/share/doc/openssl/html/man3/SSL_shutdown.html
  Parser.c: loadable library and perl binaries are mismatched (got handshake key 0xdb00080, needed 0xdb80080)
  install ./doc/ssl/SSL_state_string.pod -> /home/steffen/usr/opt/.ssl-1.1.0/share/doc/openssl/html/man3/SSL_state_string.html
  Parser.c: loadable library and perl binaries are mismatched (got handshake key 0xdb00080, needed 0xdb80080)

 |> This is v5.24 on a Linux system, and it flawless afaik.
 |
 |Are you sure that you don't have perl modules that you installed separately
 |with an earlier perl version? You may need to update those.

An incredible amount thereof!  You are using HTML::Parser?

  HTML::Parser                              3.7100  3.7200

 |Either way, this is not an OpenSSL issue, it's a perl one. Closing th\
 |is ticket.

Sorry for the noise!
Please don't mind.
Ciao.

--steffen
--
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
Reply | Threaded
Open this post in threaded view
|

Re: [openssl.org #4556] Unknown: mysterious perl(1) error during [master:8d054a5] installation process

Rich Salz via RT
I hope i don't "open" this one!

Richard Levitte via RT <[hidden email]> wrote:
 |On Thu Jun 02 15:50:31 2016, [hidden email] wrote:
 |> I have never seen something like this:
 |>
 |> Parser.c: loadable library and perl binaries are mismatched (got
 |> handshake key 0xdb00080, needed 0xdb80080)

I should have added that is happened during HTML creation
/ installation at first, sorry for that!

  install ./doc/ssl/SSL_set_verify_result.pod -> /home/steffen/usr/opt/.ssl-1.1.0/share/doc/openssl/html/man3/SSL_set_verify_result.html
  Parser.c: loadable library and perl binaries are mismatched (got handshake key 0xdb00080, needed 0xdb80080)
  install ./doc/ssl/SSL_shutdown.pod -> /home/steffen/usr/opt/.ssl-1.1.0/share/doc/openssl/html/man3/SSL_shutdown.html
  Parser.c: loadable library and perl binaries are mismatched (got handshake key 0xdb00080, needed 0xdb80080)
  install ./doc/ssl/SSL_state_string.pod -> /home/steffen/usr/opt/.ssl-1.1.0/share/doc/openssl/html/man3/SSL_state_string.html
  Parser.c: loadable library and perl binaries are mismatched (got handshake key 0xdb00080, needed 0xdb80080)

 |> This is v5.24 on a Linux system, and it flawless afaik.
 |
 |Are you sure that you don't have perl modules that you installed separately
 |with an earlier perl version? You may need to update those.

An incredible amount thereof!  You are using HTML::Parser?

  HTML::Parser                              3.7100  3.7200

 |Either way, this is not an OpenSSL issue, it's a perl one. Closing th\
 |is ticket.

Sorry for the noise!
Please don't mind.
Ciao.

--steffen


--
Ticket here: http://rt.openssl.org/Ticket/Display.html?id=4556
Please log in as guest with password guest if prompted

--
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev