[openssl.org #4504] Openssl cms encrypt bug.

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[openssl.org #4504] Openssl cms encrypt bug.

Rich Salz via RT
Fixed now, thanks for the report.

Steve.
--
Dr Stephen N. Henson. OpenSSL project core developer.
Commercial tech support now available see: http://www.openssl.org

--
Ticket here: http://rt.openssl.org/Ticket/Display.html?id=4504
Please log in as guest with password guest if prompted

--
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
Reply | Threaded
Open this post in threaded view
|

Re: [openssl.org #4504] Openssl cms encrypt bug.

Rich Salz via RT
Hi, Stephen.

One more bug was found with enc option.


I want encrypt and decrypt any text with cipher "-des-ede3-cfb1". I used
"curl -h" to generete text.

curl -h | openssl enc -des-ede3-cfb1 -pass pass:test | openssl enc -d
-des-ede3-cfb1 -pass pass:test

Looks like openssl encrypts text with error or openssl can't decrypt text
correctly.

Thanks,
Andrew

2016-05-06 4:05 GMT+05:00 Stephen Henson via RT <[hidden email]>:

> Fixed now, thanks for the report.
>
> Steve.
> --
> Dr Stephen N. Henson. OpenSSL project core developer.
> Commercial tech support now available see: http://www.openssl.org
>
> --
> Ticket here: http://rt.openssl.org/Ticket/Display.html?id=4504
> Please log in as guest with password guest if prompted
>
>

--
Ticket here: http://rt.openssl.org/Ticket/Display.html?id=4504
Please log in as guest with password guest if prompted

--
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
Reply | Threaded
Open this post in threaded view
|

Re: [openssl.org #4504] Openssl cms encrypt bug.

Michel
Hi Andrew,

I seem to recall that depending of the OpenSSL version, there was issue with
CFB1 mode.

Michel.
 
-----Message d'origine-----
De : openssl-dev [mailto:[hidden email]] De la part de
?????? ????????? via RT
Envoyé : lundi 7 novembre 2016 11:40
Cc : [hidden email]
Objet : Re: [openssl-dev] [openssl.org #4504] Openssl cms encrypt bug.

Hi, Stephen.

One more bug was found with enc option.


I want encrypt and decrypt any text with cipher "-des-ede3-cfb1". I used
"curl -h" to generete text.

curl -h | openssl enc -des-ede3-cfb1 -pass pass:test | openssl enc -d
-des-ede3-cfb1 -pass pass:test

Looks like openssl encrypts text with error or openssl can't decrypt text
correctly.

Thanks,
Andrew



--
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
Reply | Threaded
Open this post in threaded view
|

Re: [openssl.org #4504] Openssl cms encrypt bug.

Rich Salz via RT
Hi Andrew,

I seem to recall that depending of the OpenSSL version, there was issue with
CFB1 mode.

Michel.
 
-----Message d'origine-----
De : openssl-dev [mailto:[hidden email]] De la part de
?????? ????????? via RT
Envoyé : lundi 7 novembre 2016 11:40
Cc : [hidden email]
Objet : Re: [openssl-dev] [openssl.org #4504] Openssl cms encrypt bug.

Hi, Stephen.

One more bug was found with enc option.


I want encrypt and decrypt any text with cipher "-des-ede3-cfb1". I used
"curl -h" to generete text.

curl -h | openssl enc -des-ede3-cfb1 -pass pass:test | openssl enc -d
-des-ede3-cfb1 -pass pass:test

Looks like openssl encrypts text with error or openssl can't decrypt text
correctly.

Thanks,
Andrew




--
Ticket here: http://rt.openssl.org/Ticket/Display.html?id=4504
Please log in as guest with password guest if prompted

--
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev