[openssl.org #1155] openssl-0.9.8 causes MS Windows fatal error when executing 'openssl exngine xxx'

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[openssl.org #1155] openssl-0.9.8 causes MS Windows fatal error when executing 'openssl exngine xxx'

Rich Salz via RT

-------------------------------
OS: MS Windows XP Pro
Environment: MS VC 6.0
-------------------------------
set environment VC:
        c:\Program Files\Microsoft Visual Studio\VC98\Bin\VCVARS32.BAT

untar openssl-0.9.8.tar.gz

Successfully compiled it:
        perl Configure VC-WIN32
        ms\do_ms
        nmake -f ms\ntdll.mak
       
Successfully ran all tests:
        cd out32dll
  ..\ms\test
-------------------------------  
Tried:
        openssl engine xxx

Received MS fatal error:
        openssl.exe has encountered a problem and needs to close.We
are sory for the inconvinience.
-------------------------------  
Changed ..\openssl-0.9.8\crypto\engine\eng_list.c:
        Line: 386
         old:   #if 0
         new:   #if 1
         
Recompiled, ran all tests:
        No problem
   
Tried:
        openssl engine xxx
       
Received expected result :
        3420:error:2606A074:engine routines:ENGINE_by_id:no such
engine:.\crypto\engine\eng_list.c:390:id=xxx
-------------------------------
Who's going to fix it in order not to receive the mentioned MS Fatal
error ?
       
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
Development Mailing List                       [hidden email]
Automated List Manager                           [hidden email]