[openssl.org #1148] 0.9.8 PEM_F_DEF_CALLBACK incompatible API change

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[openssl.org #1148] 0.9.8 PEM_F_DEF_CALLBACK incompatible API change

Rich Salz via RT

openssl-0.9.8 breaks the current (2.8.22) release of mod_ssl

This is due to an incompatible API change: PEM_F_DEF_CALLBACK was renamed to
PEM_F_PEM_DEF_CALLBACK

I think this should have been mentioned in the announcement, or at least in
the CHANGES file or at http://www.openssl.org/news/changelog.html

______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
Development Mailing List                       [hidden email]
Automated List Manager                           [hidden email]