[openssl.org #1094] openssl-0.9.8-beta3 doesn't build on Linux IA64

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[openssl.org #1094] openssl-0.9.8-beta3 doesn't build on Linux IA64

Rich Salz via RT

I think I resolved this.  Configure erroneously refered to ia64.o
instead of bn-ia64.o...  Fix committed and will be part of beta4.  
Thanks for the notification.

Ticket resolved.  If there is still a problem with this, please generate
a new bug report.

[[hidden email] - Fri Jun  3 12:58:08 2005]:

> System:
>     SuSE SLES-8 (ia64)
>     VERSION = 8.1
>
> Source tarball:
>     openssl-0.9.8-beta3.tar.gz
>
> Build commands:
>     tar zxf openssl-0.9.8-beta3.tar.gz
>     cd openssl-0.9.8-beta3
>     ./config --prefix=/users/kst/local/apps/openssl-0.9.8-beta3
>     make
>
> Output (partial):
>
> gcc -I.. -I../.. -I../../include -DOPENSSL_THREADS -D_REENTRANT
> -DDSO_DLFCN -DHAVE_DLFCN_H -DL_ENDIAN -DTERMIO -O3 -Wall -DSHA1_ASM
> -DSHA256_ASM -DSHA512_ASM -DAES_ASM   -c -o bn_sqr.o bn_sqr.c
> make[2]: *** No rule to make target `ia64.o', needed by `lib'.  Stop.
> make[2]: Leaving directory `/users/kst/src/openssl/openssl-0.9.8-
> beta3/crypto/bn'
> make[1]: *** [subdirs] Error 1
> make[1]: Leaving directory `/users/kst/src/openssl/openssl-0.9.8-
> beta3/crypto'
> make: *** [build_crypto] Error 1
>
> I see the same problem with openssl-SNAP-20050602.tar.gz .
>
> More details available on request.


--
Richard Levitte
[hidden email]
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
Development Mailing List                       [hidden email]
Automated List Manager                           [hidden email]