openssl-1.1.1-pre6 throws plenty of "Warning: -xarch=v9 is deprecated, use -m64 -xarch=sparc instead"

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

openssl-1.1.1-pre6 throws plenty of "Warning: -xarch=v9 is deprecated, use -m64 -xarch=sparc instead"

Dennis Clarke-2


On Solaris 10 sparc with Oracle Studio 12.6 this is perhaps merely an
annoyance.

If I entirely leave Configurations/10-main.conf untouched and go with
the cflags suggested then I get warnings on every compile :

.
.
.
cc  -I. -Icrypto/include -Iinclude -KPIC -xarch=v9 -xstrconst -Xa -xO5
-xdepend -DFILIO_H -DB_ENDIAN -DBN_DIV2W -DOPENSSL_PIC
-DOPENSSL_CPUID_OBJ -DOPENSSL_BN_ASM_MONT -DOPENSSL_BN_ASM_GF2m
-DSHA1_ASM -DSHA256_ASM -DSHA512_ASM -DMD5_ASM -DAES_ASM -DGHASH_ASM
-DECP_NISTZ256_ASM -DPOLY1305_ASM -DOPENSSLDIR="\"/usr/local/ssl\""
-DENGINESDIR="\"/usr/local/lib/engines-1.1\"" -D_REENTRANT -DNDEBUG   -c
-o crypto/cms/cms_io.o crypto/cms/cms_io.c
cc: Warning: -xarch=v9 is deprecated, use -m64 -xarch=sparc instead


May be best to change cflags for solaris64-sparcv9-cc slightly.


Dennis

--
openssl-users mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-users