openSSL 1.1.1b compatibility with GLIBC

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

openSSL 1.1.1b compatibility with GLIBC

Chethan Kumar

Dear all,

 

In need of some assistance. I compiled openssl1.1.1b on Debian and executed openssl commands on another Debian machine.

Its giving below error:

openssl: /lib/i386-linux-gnu/libc.so.6: version `GLIBC_2.25' not found (required by /home/SYSROM_SRC/build/release/lib/libcrypto.so.1.1)

 

Even when I start HTTP services which uses openssl gives same error.

Starting webserverhttpd: Syntax error on line 208 of /config/httpd.conf: Cannot load lib/mod_ssl.so into server: /lib/i386-linux-gnu/libc.so.6: version `GLIBC_2.25' not found (required by /usr/local/ebx/lib/libcrypto.so.1.1)

 

Environment used for the same is below:

Compilation Environment:

cat /proc/version

Linux version 3.16.0-6-amd64 ([hidden email]) (gcc version 4.9.2 (Debian 4.9.2-10+deb8u1) )

 

ldd --version

ldd (Debian GLIBC 2.19-18+deb8u10) 2.19

 

Executing Environment:

cat /proc/version

Linux version 4.4.130-cip23-eBN-kernel (jenkins@skelios-plt) (gcc version 4.9.2 (Debian 4.9.2-10+deb8u1) )

 

ldd --version

ldd (GNU libc) 2.19

 

I need to know, how did the compilation was successful though GLIBC version was less and what should be done to make it work apart from updating GLIBC.

 

Thanking you,

Chethan Kumar

 

The information contained in this e-mail message and in any attachments/annexure/appendices is confidential to the
recipient and may contain privileged information. If you are not the intended recipient, please notify the
sender and delete the message along with any attachments/annexure/appendices. You should not disclose,
copy or otherwise use the information contained in the message or any annexure. Any views expressed in this e-mail
are those of the individual sender except where the sender specifically states them to be the views of 
Toshiba Software India Pvt. Ltd. (TSIP),Bangalore.
Although this transmission and any attachments are believed to be free of any virus or other defect that might affect any computer system into which it is received and opened, it is the responsibility of the recipient to ensure that it is virus free and no responsibility is accepted by Toshiba Software India Pvt. Ltd, for any loss or damage arising in any way from its use.

Reply | Threaded
Open this post in threaded view
|

Re: openSSL 1.1.1b compatibility with GLIBC

OpenSSL - User mailing list
On 01/03/2019 12:38, Chethan Kumar wrote:

>
> Dear all,
>
> In need of some assistance. I compiled openssl1.1.1b on Debian and
> executed openssl commands on another Debian machine.
>
> Its giving below error:
>
> openssl: */lib/i386-linux-gnu/libc.so.6: version `GLIBC_2.25' not
> found (required by /home/SYSROM_SRC/build/release/lib/libcrypto.so.1.1)*
>
Debian glibc versions with a given so-name (such as
libc.so.6) are backwards compatible, but not forward
compatible.

Thus compiling against glibc from an older version of Debian 8
(jessie) such as Debian glibc 2.19-18 should work with glibc
from a later version (such as "Debian GLIBC 2.19-18+deb8u10").
  But the other way around is not guaranteed to work, nor is
running with a non-Debian glibc when compiled against a Debian
glibc.

Your executing environment seems to contain a glibc which is
a plain version 2.19 with none of the Debian fixes added
between May 2014 and 16 Jun 2017 (see the file
/usr/share/doc/libc6/changelog.Debian.gz).

The package versions that need to match (or be in the correct
order) are package libc6-dev (when compiling) being same or
older than libc6 when running.

The command "dpkg --compare-versions" compares package
version numbers according to the correct rules.

When using the Debian packaging tools to package a compiled
file such as libcrypto.so.1.1, the resulting .deb file will
typically instruct the system to not install it unless a new
enough glibc is installed in the executing environment.

> Even when I start HTTP services which uses openssl gives same error.
>
> Starting webserverhttpd: Syntax error on line 208 of
> /config/httpd.conf: Cannot load lib/mod_ssl.so into server:
> */lib/i386-linux-gnu/libc.so.6: version `GLIBC_2.25' not found
> (required by /usr/local/ebx/lib/libcrypto.so.1.1)*
>
> Environment used for the same is below:
>
> *Compilation Environment:*
>
> cat /proc/version
>
> Linux version 3.16.0-6-amd64 ([hidden email]) (gcc
> version 4.9.2 (Debian 4.9.2-10+deb8u1) )
>
> ldd --version
>
> ldd (Debian GLIBC 2.19-18+deb8u10) 2.19
>
> **
>
> *Executing Environment:*
>
> cat /proc/version
>
> Linux version 4.4.130-cip23-eBN-kernel (jenkins@skelios-plt) (gcc
> version 4.9.2 (Debian 4.9.2-10+deb8u1) )
>
> ldd --version
>
> ldd (GNU libc) 2.19
>
> I need to know, how did the compilation was successful though GLIBC
> version was less and what should be done to make it work apart from
> updating GLIBC.
>
>

Enjoy

Jakob
--
Jakob Bohm, CIO, Partner, WiseMo A/S.  https://www.wisemo.com
Transformervej 29, 2860 Søborg, Denmark.  Direct +45 31 13 16 10
This public discussion message is non-binding and may contain errors.
WiseMo - Remote Service Management for PCs, Phones and Embedded