master branch: EC test broken AGAIN?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

master branch: EC test broken AGAIN?

Blumenthal, Uri - 0553 - MITLL

Test Summary Report

-------------------

../test/recipes/15-test_ec.t                     (Wstat: 256 Tests: 5 Failed: 1)

  Failed test:  2

  Non-zero exit status: 1

Files=174, Tests=1660, 122 wallclock secs ( 1.27 usr  0.34 sys + 81.53 cusr 29.91 csys = 113.05 CPU)

Result: FAIL

 

Does it seem to have become repetitive? ;-)

-- 

Regards,

Uri


smime.p7s (7K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: master branch: EC test broken AGAIN?

Matt Caswell-2


On 07/08/2019 15:48, Blumenthal, Uri - 0553 - MITLL wrote:

> Test Summary Report
>
> -------------------
>
> ../test/recipes/15-test_ec.t                     (Wstat: 256 Tests: 5 Failed: 1)
>
>   Failed test:  2
>
>   Non-zero exit status: 1
>
> Files=174, Tests=1660, 122 wallclock secs ( 1.27 usr  0.34 sys + 81.53 cusr
> 29.91 csys = 113.05 CPU)
>
> Result: FAIL
>
>  
>
> Does it seem to have become repetitive? ;-)

Assuming you are building with enable-ec_nistp_64_gcc_128 then the fix for this
issue is here:

https://github.com/openssl/openssl/pull/9546

Matt
Reply | Threaded
Open this post in threaded view
|

Re: master branch: EC test broken AGAIN?

Matt Caswell-2


On 07/08/2019 15:49, Matt Caswell wrote:

>
>
> On 07/08/2019 15:48, Blumenthal, Uri - 0553 - MITLL wrote:
>> Test Summary Report
>>
>> -------------------
>>
>> ../test/recipes/15-test_ec.t                     (Wstat: 256 Tests: 5 Failed: 1)
>>
>>   Failed test:  2
>>
>>   Non-zero exit status: 1
>>
>> Files=174, Tests=1660, 122 wallclock secs ( 1.27 usr  0.34 sys + 81.53 cusr
>> 29.91 csys = 113.05 CPU)
>>
>> Result: FAIL
>>
>>  
>>
>> Does it seem to have become repetitive? ;-)
>
> Assuming you are building with enable-ec_nistp_64_gcc_128 then the fix for this
> issue is here:
>
> https://github.com/openssl/openssl/pull/9546

...now pushed to master.

Matt

Reply | Threaded
Open this post in threaded view
|

Re: master branch: EC test broken AGAIN?

Blumenthal, Uri - 0553 - MITLL
On 8/7/19, 10:57 AM, "openssl-users on behalf of Matt Caswell" <[hidden email] on behalf of [hidden email]> wrote:
  >  >> ../test/recipes/15-test_ec.t                     (Wstat: 256 Tests: 5 Failed: 1)
   > >
   > > Assuming you are building with enable-ec_nistp_64_gcc_128 then the fix for this
   > > issue is here:
   > >
   > > https://github.com/openssl/openssl/pull/9546
   >
   > ...now pushed to master.

Thank you - yes the build was with "enable-ec_nistp_64_gcc_128", and I confirm that the fix works.
   
   
   

smime.p7s (7K) Download Attachment