mactel install?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

mactel install?

John Russell-2
./Configure darwin-i386-cc --prefix=/usr/webtools05/apache2 --
openssldir=/usr/webtools05/apache2/

Install on mac (intel) fails with

collect2: ld returned 1 exit status
make[2]: *** [link_app.] Error 1
make[1]: *** [openssl] Error 2
make: *** [build_apps] Error 1


This is the recommended way for making perl, dont know if it is helpful


     export SDK=/Developer/SDKs/MacOSX10.4u.sdk

In addition to the compiler flags used to select the SDK, also add  
the flags
for creating a universal binary:

     ./Configure -Accflags="-arch i686 -arch ppc -nostdinc -B$SDK/usr/
include/gcc \
                            -B$SDK/usr/lib/gcc -isystem$SDK/usr/
include \
                            -F$SDK/System/Library/Frameworks" \
                 -Aldflags="-arch i686 -arch ppc -Wl,-syslibroot,$SDK" \
                 -de

Any suggestions on what to try?


______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: mactel install?

Nils Larsch
John Russell wrote:

> ./Configure darwin-i386-cc --prefix=/usr/webtools05/apache2
> --openssldir=/usr/webtools05/apache2/
>
> Install on mac (intel) fails with
>
> collect2: ld returned 1 exit status
> make[2]: *** [link_app.] Error 1
> make[1]: *** [openssl] Error 2
> make: *** [build_apps] Error 1
>
>
> This is the recommended way for making perl, dont know if it is helpful
>
>
>     export SDK=/Developer/SDKs/MacOSX10.4u.sdk
>
> In addition to the compiler flags used to select the SDK, also add the
> flags
> for creating a universal binary:
>
>     ./Configure -Accflags="-arch i686 -arch ppc -nostdinc
> -B$SDK/usr/include/gcc \
>                            -B$SDK/usr/lib/gcc -isystem$SDK/usr/include \
>                            -F$SDK/System/Library/Frameworks" \
>                 -Aldflags="-arch i686 -arch ppc -Wl,-syslibroot,$SDK" \
>                 -de
>
> Any suggestions on what to try?

difficult to say as you didn't give us information about the openssl
version you've tried etc.. In case it was 0.9.8a try a recent snapshot.

Nils
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]