install error with linux mint 19.1

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

install error with linux mint 19.1

sebastien

hi

in a terminal I've got this error with

openssl version

openssl: /usr/lib/x86_64-linux-gnu/libssl.so.1.1: version `OPENSSL_1_1_1' not found (required by openssl)
openssl: /usr/lib/x86_64-linux-gnu/libcrypto.so.1.1: version `OPENSSL_1_1_1' not found (required by openssl)

can you please help me ?


Reply | Threaded
Open this post in threaded view
|

Re: install error with linux mint 19.1

OpenSSL - User mailing list
On 25/03/2019 22:53, sebastien wrote:
>
> hi
>
> in a terminal I've got this error with
>
> |openssl version openssl: /usr/lib/x86_64-linux-gnu/libssl.so.1.1:
> version `OPENSSL_1_1_1' not found (required by openssl) openssl:
> /usr/lib/x86_64-linux-gnu/libcrypto.so.1.1: version `OPENSSL_1_1_1'
> not found (required by openssl) can you please help me ? |
I guess the files |/usr/lib/x86_64-linux-gnu/libssl.so.1.1 and
||/usr/lib/x86_64-linux-gnu/libcrypto.so.1.1|||are the system installed
OpenSSL 1.1.0 libraries and your freshly compiled openssl 1.1.1
program is is trying to load them instead of it's own version 1.1.1
libraries.

If so, try testing withthe command

LD_LIBRARY_PATH=/home/your/openssl-1.1.1-build-dir/somewhere openssl version

to force use of your not-yet-installed OpenSSL 1.1.1 libraries.

Enjoy

Jakob
--
Jakob Bohm, CIO, Partner, WiseMo A/S.  https://www.wisemo.com
Transformervej 29, 2860 Søborg, Denmark.  Direct +45 31 13 16 10
This public discussion message is non-binding and may contain errors.
WiseMo - Remote Service Management for PCs, Phones and Embedded