Quantcast

download openssl-devel for mod_dev

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

download openssl-devel for mod_dev

csross

Hi,

 

I’m trying to install apache2-compatible mod_dav and my compile said I needed

 

checking for sslc.h... no

no SSL-C headers found

configure: error: ...No recognized SSL/TLS toolkit detected

 

I compiled v0.9.8g from scratch (openssl-0.9.8g.tar.gz) but I guess the headers are not included.

 

Where can I just get openssl-devel (as research shows I need that).

 

Thank you.

 

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: download openssl-devel for mod_dev

g.esp
Selon Christine Ross <[hidden email]>:

> Hi,
>
>
>
> I'm trying to install apache2-compatible mod_dav and my compile said I
> needed
>
>
>
> checking for sslc.h... no
>
that's not an openssl file.

> no SSL-C headers found
>
> configure: error: ...No recognized SSL/TLS toolkit detected
>
>
>
> I compiled v0.9.8g from scratch (openssl-0.9.8g.tar.gz) but I guess the
> headers are not included.
>
headers may be not include in (not devel) rpm but compiling from scratch, you
have everything for sure.
>
> Where can I just get openssl-devel (as research shows I need that).
>
>
Does that help
http://www.mail-archive.com/dev@.../msg15957.html


Gilles
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
Development Mailing List                       [hidden email]
Automated List Manager                           [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: download openssl-devel for mod_dev

csross
Hello,

I will try, thank you.  If I compiled and installed openssl from source,
does that mean I have all the header files included, like the one
referenced in the error?  Is there another source that includes the
headers?   I do not have that file on the system (Solaris 8).

Sincerely,
Christine Ross

HCCS - Experts in Healthcare Learning
(516)478-4100, x108
[hidden email]

HCCS is the leading provider of effective online training courses and
learning management systems to healthcare facilities.   HCCS has
provided over 2.5 million hours of compliance and competency training
courseware to hospitals, teaching facilities, medical schools, health
plans and other health care entities.  The HCCS Compliance Learning
Library contains expert training content in the areas of Medicare,
Medicaid, HIPAA, Harassment, Research, Patient Safety and Quality
Improvement Compliance.  The HCCS Healthcare Learning Platform (HLP) is
a healthcare specific Learning and Competency Management System.
http://www.hccs.com (516) 478-4100 or (877) 933-hccs.

This email message is for the sole use of the intended recipient(s) and
contains confidential and privileged information. Any unauthorized
review, use, disclosure or distribution is strictly prohibited. If you
are not the intended recipient or have received this communication in
error please contact the sender by reply e-mail and destroy all copies
of the original message. Thank you.
 

-----Original Message-----
From: Gilles Espinasse [mailto:[hidden email]]
Sent: Wednesday, April 22, 2009 4:24 AM
To: Christine Ross
Cc: [hidden email]
Subject: Re: download openssl-devel for mod_dev

Selon Christine Ross <[hidden email]>:

> Hi,
>
>
>
> I'm trying to install apache2-compatible mod_dav and my compile said I
> needed
>
>
>
> checking for sslc.h... no
>
that's not an openssl file.

> no SSL-C headers found
>
> configure: error: ...No recognized SSL/TLS toolkit detected
>
>
>
> I compiled v0.9.8g from scratch (openssl-0.9.8g.tar.gz) but I guess
the
> headers are not included.
>
headers may be not include in (not devel) rpm but compiling from
scratch, you
have everything for sure.
>
> Where can I just get openssl-devel (as research shows I need that).
>
>
Does that help
http://www.mail-archive.com/dev@.../msg15957.html


Gilles
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
Development Mailing List                       [hidden email]
Automated List Manager                           [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: download openssl-devel for mod_dev

csross
In reply to this post by g.esp
Hi,

I didn't see the line about having everything if I compile from scratch.
Thank you.

Am I correct in assuming that I use that option -DHAVE_OPENSSL to
compile apache?  I already have --enable-ssl --with-ssl=/usr/local/ssl
in my configure line.

Thank you

Sincerely,
Christine Ross

HCCS - Experts in Healthcare Learning
(516)478-4100, x108
[hidden email]

HCCS is the leading provider of effective online training courses and
learning management systems to healthcare facilities.   HCCS has
provided over 2.5 million hours of compliance and competency training
courseware to hospitals, teaching facilities, medical schools, health
plans and other health care entities.  The HCCS Compliance Learning
Library contains expert training content in the areas of Medicare,
Medicaid, HIPAA, Harassment, Research, Patient Safety and Quality
Improvement Compliance.  The HCCS Healthcare Learning Platform (HLP) is
a healthcare specific Learning and Competency Management System.
http://www.hccs.com (516) 478-4100 or (877) 933-hccs.

This email message is for the sole use of the intended recipient(s) and
contains confidential and privileged information. Any unauthorized
review, use, disclosure or distribution is strictly prohibited. If you
are not the intended recipient or have received this communication in
error please contact the sender by reply e-mail and destroy all copies
of the original message. Thank you.
 

-----Original Message-----
From: Gilles Espinasse [mailto:[hidden email]]
Sent: Wednesday, April 22, 2009 4:24 AM
To: Christine Ross
Cc: [hidden email]
Subject: Re: download openssl-devel for mod_dev

Selon Christine Ross <[hidden email]>:

> Hi,
>
>
>
> I'm trying to install apache2-compatible mod_dav and my compile said I
> needed
>
>
>
> checking for sslc.h... no
>
that's not an openssl file.

> no SSL-C headers found
>
> configure: error: ...No recognized SSL/TLS toolkit detected
>
>
>
> I compiled v0.9.8g from scratch (openssl-0.9.8g.tar.gz) but I guess
the
> headers are not included.
>
headers may be not include in (not devel) rpm but compiling from
scratch, you
have everything for sure.
>
> Where can I just get openssl-devel (as research shows I need that).
>
>
Does that help
http://www.mail-archive.com/dev@.../msg15957.html


Gilles
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
Development Mailing List                       [hidden email]
Automated List Manager                           [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: download openssl-devel for mod_dev

g.esp
Selon Christine Ross <[hidden email]>:

> Hi,
>
> I didn't see the line about having everything if I compile from scratch.
> Thank you.
>
> Am I correct in assuming that I use that option -DHAVE_OPENSSL to
> compile apache?  I already have --enable-ssl --with-ssl=/usr/local/ssl
> in my configure line.
>
I don't know for solaris but on linux, configure find the headers on it's own
and there is no need to hack adding -DHAVE_OPENSSL. Should be tried on very last
attempt.

--with-ssl directive should be for the case you have differents ssl versions
installed.
Have you try without --with-ssl?

Here is what I find for a not to old apache compilation on Solaris
http://www.nies.ch/doc/apache-ldap-webdav.en.php


Gilles
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
Development Mailing List                       [hidden email]
Automated List Manager                           [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: download openssl-devel for mod_dev

csross
Hi and thank you,

I'm trying the "make" on its own.  The configure given me an error but I
believe it was with the make.

Sincerely,
Christine Ross

HCCS - Experts in Healthcare Learning
(516)478-4100, x108
[hidden email]

HCCS is the leading provider of effective online training courses and
learning management systems to healthcare facilities.   HCCS has
provided over 2.5 million hours of compliance and competency training
courseware to hospitals, teaching facilities, medical schools, health
plans and other health care entities.  The HCCS Compliance Learning
Library contains expert training content in the areas of Medicare,
Medicaid, HIPAA, Harassment, Research, Patient Safety and Quality
Improvement Compliance.  The HCCS Healthcare Learning Platform (HLP) is
a healthcare specific Learning and Competency Management System.
http://www.hccs.com (516) 478-4100 or (877) 933-hccs.
This email message is for the sole use of the intended recipient(s) and
contains confidential and privileged information. Any unauthorized
review, use, disclosure or distribution is strictly prohibited. If you
are not the intended recipient or have received this communication in
error please contact the sender by reply e-mail and destroy all copies
of the original message. Thank you.
 

-----Original Message-----
From: Gilles Espinasse [mailto:[hidden email]]
Sent: Wednesday, April 22, 2009 10:32 AM
To: Christine Ross
Cc: [hidden email]
Subject: RE: download openssl-devel for mod_dev

Selon Christine Ross <[hidden email]>:

> Hi,
>
> I didn't see the line about having everything if I compile from
scratch.
> Thank you.
>
> Am I correct in assuming that I use that option -DHAVE_OPENSSL to
> compile apache?  I already have --enable-ssl --with-ssl=/usr/local/ssl
> in my configure line.
>
I don't know for solaris but on linux, configure find the headers on
it's own
and there is no need to hack adding -DHAVE_OPENSSL. Should be tried on
very last
attempt.

--with-ssl directive should be for the case you have differents ssl
versions
installed.
Have you try without --with-ssl?

Here is what I find for a not to old apache compilation on Solaris
http://www.nies.ch/doc/apache-ldap-webdav.en.php


Gilles
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
Development Mailing List                       [hidden email]
Automated List Manager                           [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: download openssl-devel for mod_dev

g.esp
Selon Christine Ross <[hidden email]>:

> Hi and thank you,
>
> I'm trying the "make" on its own.  The configure given me an error but I
> believe it was with the make.
>
You should use gmake on solaris, no?


Gilles
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
Development Mailing List                       [hidden email]
Automated List Manager                           [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: download openssl-devel for mod_dev

csross
Hi,

Thanks.

I was able to compile and install without issue.  Thank you very much.

Sincerely,
Christine Ross

HCCS - Experts in Healthcare Learning
(516)478-4100, x108
[hidden email]

HCCS is the leading provider of effective online training courses and
learning management systems to healthcare facilities.   HCCS has
provided over 2.5 million hours of compliance and competency training
courseware to hospitals, teaching facilities, medical schools, health
plans and other health care entities.  The HCCS Compliance Learning
Library contains expert training content in the areas of Medicare,
Medicaid, HIPAA, Harassment, Research, Patient Safety and Quality
Improvement Compliance.  The HCCS Healthcare Learning Platform (HLP) is
a healthcare specific Learning and Competency Management System.
http://www.hccs.com (516) 478-4100 or (877) 933-hccs.

This email message is for the sole use of the intended recipient(s) and
contains confidential and privileged information. Any unauthorized
review, use, disclosure or distribution is strictly prohibited. If you
are not the intended recipient or have received this communication in
error please contact the sender by reply e-mail and destroy all copies
of the original message. Thank you.
 
-----Original Message-----
From: Gilles Espinasse [mailto:[hidden email]]
Sent: Wednesday, April 22, 2009 11:29 AM
To: Christine Ross
Cc: [hidden email]
Subject: RE: download openssl-devel for mod_dev

Selon Christine Ross <[hidden email]>:

> Hi and thank you,
>
> I'm trying the "make" on its own.  The configure given me an error but
I
> believe it was with the make.
>
You should use gmake on solaris, no?


Gilles
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
Development Mailing List                       [hidden email]
Automated List Manager                           [hidden email]
Loading...