bug? missing link paths to ssl/crypto libs for OpenSSL ver >= 0.9.8; v <= 0.9.7 is OK

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

bug? missing link paths to ssl/crypto libs for OpenSSL ver >= 0.9.8; v <= 0.9.7 is OK

OpenMacNews
hi all,

from what i'm seeing, this may be directly a SSL issue .. thought i'd check
here!

i'm building ssl-dependent pkgs on OSX 10.4.2.  i've used my own external
builds of OpenSSL for ages, w/ virtually no problems.

i've just upgraded from openssl from v0.9.7 --> v0.9.8, built into
/usr/local/ssl.

i've noticed a change in linking behavior w/ the version change ...

upon examination of resultant binaries -- e.g., with 'lynx', or any other
ssl-dependent app, for that matter --

when built against v0.9.7, 'otool -L' on the resultant binary shows:

        % otool -L /usr/local/bin/lynx
          /usr/local/lib/libz.1.dylib (compatibility version 1.0.0, current version
1.2.2)
          /usr/local/ncurses/lib/libncursesw.5.4.dylib (compatibility version 5.4.0,
current version 5.4.0)
          /usr/local/ssl/lib/libssl.0.9.7.dylib (compatibility version 0.9.0, current
version 0.9.7)
          /usr/local/ssl/lib/libcrypto.0.9.7.dylib (compatibility version 0.9.0,
current version 0.9.7)
          /usr/lib/libmx.A.dylib (compatibility version 1.0.0, current version 92.0.0)
          /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version
88.0.0)

whereas on the v0.9.8-linked binary, i find:

        % otool -L /usr/local/bin/lynx
          /usr/local/lib/libz.1.dylib (compatibility version 1.0.0, current version
1.2.2)
          /usr/local/ncurses/lib/libncursesw.5.4.dylib (compatibility version 5.4.0,
current version 5.4.0)
          libssl.0.9.8.dylib (compatibility version 0.9.8, current version 0.9.8)
          libcrypto.0.9.8.dylib (compatibility version 0.9.8, current version 0.9.8)
          /usr/lib/libmx.A.dylib (compatibility version 1.0.0, current version 92.0.0)
          /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version
88.0.0)


NOTE: the lack of a precedent path (/usr/local/ssl/lib) for the
libssl*/libcrypto* link components in the latter case.


QUESTION:

why is this occuring?  is this a problem?

i've looked through bunches of my built apps, pkgs, libs, etc., ad this ONLY
occures wrt OpenSSL's libs for v >= 0.9.8

thx for any/all comments!

cheers,

richard

______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
Development Mailing List                       [hidden email]
Automated List Manager                           [hidden email]