Use of engines in 0.9.8a -- "can't use that engine" errors

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Use of engines in 0.9.8a -- "can't use that engine" errors

Warren Gavin
Hello,

I have installed OpenSSL 0.9.8a and have been trying to get it to work
with an nCipher nShield HSM.

I get the following error when running various openssl commands, e.g.

$ openssl genrsa -engine chil 512
can't use that engine
2258:error:84067072:CHIL engine:HWCRHK_INIT:locking
missing:e_chil.c:594:You HAVE to add dynamic locking callbacks via
CRYPTO_set_dynlock_{create,lock,destroy}_callback()
2258:error:260B806D:engine routines:ENGINE_TABLE_REGISTER:init
failed:eng_table.c:161:

I have set LD_LIBRARY_PATH to include /opt/nfast/toolkits/hwcrhk. Is
there something else I'm missing, or has the introduction of the
'dynamic' type caused some temporary instability in 0.9.8a?

Regards


Warren
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]