Trouble installing openssl 1.1.0 on Ubuntu 14.04

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Trouble installing openssl 1.1.0 on Ubuntu 14.04

EcolaneAdam
Hello,

Several months ago I had configured ansible to deploy openssl upgrades to
our Ubuntu 14.04 servers and did so with the following version via apt
module:
        - libssl-dev=1.1.0h-2.0+ubuntu14.04.1+deb.sury.org+1
        - openssl=1.1.0h-2.0+ubuntu14.04.1+deb.sury.org+1

Now when doing deployments I am getting that the version is not found.  I am
having trouble finding the correct version to reference.  Anything I have
tried hasn't worked.

Any ideas?



--
Sent from: http://openssl.6102.n7.nabble.com/OpenSSL-User-f3.html
--
openssl-users mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-users
Reply | Threaded
Open this post in threaded view
|

Re: Trouble installing openssl 1.1.0 on Ubuntu 14.04

Richard Levitte - VMS Whacker-2
In message <[hidden email]> on Mon, 5 Nov 2018 14:51:15 -0700 (MST), EcolaneAdam <[hidden email]> said:

> Hello,
>
> Several months ago I had configured ansible to deploy openssl upgrades to
> our Ubuntu 14.04 servers and did so with the following version via apt
> module:
>         - libssl-dev=1.1.0h-2.0+ubuntu14.04.1+deb.sury.org+1
>         - openssl=1.1.0h-2.0+ubuntu14.04.1+deb.sury.org+1
>
> Now when doing deployments I am getting that the version is not found.  I am
> having trouble finding the correct version to reference.  Anything I have
> tried hasn't worked.
>
> Any ideas?

Those package names told me I could have a look at
http://deb.sury.org, and sure enough, there was something there, with
a PPA link: https://launchpad.net/~ondrej/+archive/ubuntu/php/

You can see the full (I assume) list of available packages there, and
for OpenSSL, I find these:

1.1.1-2+ubuntu18.10.1+deb.sury.org+2
1.1.1-2+ubuntu18.04.1+deb.sury.org+2
1.1.1-2+ubuntu16.04.1+deb.sury.org+2
1.1.1-2+ubuntu14.04.1+deb.sury.org+2

So it looks to me like you're being forced to upgrade.  Note that
1.1.1 is forward compatible with 1.1.0h, so that upgrade should go
smoothly.

Cheers,
Richard

--
Richard Levitte         [hidden email]
OpenSSL Project         http://www.openssl.org/~levitte/
--
openssl-users mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-users