SSL_CTX_new error SSLCERT routines:STORE_NEW:not supported

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

SSL_CTX_new error SSLCERT routines:STORE_NEW:not supported

Ambarish Mitra
I am getting the following error while calling SSL_CTX_new (meth); where
SSL_METHOD * meth; The same code is working on Windows. I am on openssl
0.9.8 on both the platforms.
[error:1A09400E:SSLCERT routines:STORE_NEW:not supported]
SSL_METHOD *meth;
#if defined(_WIN32)
WORD wVersionRequested;
WSADATA wsaData;
wVersionRequested = MAKEWORD( 2, 2 );
WSAStartup( wVersionRequested, &wsaData );
#endif
SSLeay_add_ssl_algorithms();
meth = SSLv3_client_method();
SSL_load_error_strings();
ctx = SSL_CTX_new (meth);
if (ctx == NULL)
{
unsigned long ErrCode = ERR_get_error();
char ErrBuf[120];
ERR_error_string(ErrCode, ErrBuf);
fprintf(stderr, "Error: [%s]\n", ErrBuf); // ERROR HERE
return 2;
}




winmail.dat (2K) Download Attachment