SMIME version 3 support

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

SMIME version 3 support

Perry L. Jones
Hello,

The man page for smime says that openssl does not support smime version
3. Under the BUGS section.

http://www.openssl.org/docs/apps/smime.html

Does anyone know if there is any work being done to support smime
Version 3?

If not is there possible another C api that already has support for
parsing smime version 3?

Thanks
Perry
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: SMIME version 3 support

Dr. Stephen Henson
On Fri, Mar 03, 2006, Perry L. Jones wrote:

> Hello,
>
> The man page for smime says that openssl does not support smime version
> 3. Under the BUGS section.
>
> http://www.openssl.org/docs/apps/smime.html
>
> Does anyone know if there is any work being done to support smime
> Version 3?
>

There have been many queries and discussion but so far no one has been willing
to fund the effort: it is a *lot* of work.

> If not is there possible another C api that already has support for
> parsing smime version 3?
>

In practice you rarely need S/MIME v3. Is there some specific feature you
require?

Steve.
--
Dr Stephen N. Henson. Email, S/MIME and PGP keys: see homepage
OpenSSL project core developer and freelance consultant.
Funding needed! Details on homepage.
Homepage: http://www.drh-consultancy.demon.co.uk
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: SMIME version 3 support

Perry L. Jones
I am having an issue with one of your software products.  At first it
looked like MS outlook 2003 was sending SMIME v3 email message and
SMIME_read_PKCS7 was having trouble parsing it.  I have since found that
this is not the case.  It look more like a problem in how we are parsing
other parts of the email message header.

If the issue comes back to being SMIME I will try to provide you with
more details.

Thanks,
Perry

Dr. Stephen Henson wrote:

>On Fri, Mar 03, 2006, Perry L. Jones wrote:
>
>  
>
>>Hello,
>>
>>The man page for smime says that openssl does not support smime version
>>3. Under the BUGS section.
>>
>>http://www.openssl.org/docs/apps/smime.html
>>
>>Does anyone know if there is any work being done to support smime
>>Version 3?
>>
>>    
>>
>
>There have been many queries and discussion but so far no one has been willing
>to fund the effort: it is a *lot* of work.
>
>  
>
>>If not is there possible another C api that already has support for
>>parsing smime version 3?
>>
>>    
>>
>
>In practice you rarely need S/MIME v3. Is there some specific feature you
>require?
>
>Steve.
>--
>Dr Stephen N. Henson. Email, S/MIME and PGP keys: see homepage
>OpenSSL project core developer and freelance consultant.
>Funding needed! Details on homepage.
>Homepage: http://www.drh-consultancy.demon.co.uk
>______________________________________________________________________
>OpenSSL Project                                 http://www.openssl.org
>User Support Mailing List                    [hidden email]
>Automated List Manager                           [hidden email]
>
>  
>
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]
Reply | Threaded
Open this post in threaded view
|

RE: SMIME version 3 support

Sascha Kiefer
In reply to this post by Perry L. Jones
Well, i used the MS CryptoAPI to have full support!

--sk

> -----Original Message-----
> From: [hidden email]
> [mailto:[hidden email]] On Behalf Of Perry L. Jones
> Sent: Freitag, 3. März 2006 15:15
> To: [hidden email]
> Subject: SMIME version 3 support
>
>
> Hello,
>
> The man page for smime says that openssl does not support
> smime version
> 3. Under the BUGS section.
>
> http://www.openssl.org/docs/apps/smime.html
>
> Does anyone know if there is any work being done to support smime
> Version 3?
>
> If not is there possible another C api that already has support for
> parsing smime version 3?
>
> Thanks
> Perry
> ______________________________________________________________________
> OpenSSL Project                                 http://www.openssl.org
> User Support Mailing List                    [hidden email]
> Automated List Manager                           [hidden email]
>

______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]