Re: mini-ASN.1 compiler 0.9.8-dev

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: mini-ASN.1 compiler 0.9.8-dev

pana
I found the manual page but when I try to use the command "openssl
asn1parse -genstr ..." the system answers me with "unknown option
-genstr" !!
How is it possible? bad insatallation?

bye
pana

2005/5/20, Dr. Stephen Henson <[hidden email]>:

> On Thu, May 19, 2005, pana wrote:
>
> > Hi,
> > I don't know how to use the mini-ASN.1 compiler in the openssl
> > 0.9.8-dev version.
> > I need to obtain DER octets to insert in my custom extensions. Their
> > structure is very simple, I use IA5String and BMPString.
> > For example I want something like ...=DER:00:55:00:...
> > Someone can help me?
> >
>
> Check out the manual pages to asn1parse (-genstr option) and
> ASN1_generate_nconf in 0.9.8-dev
>
> Steve.
> --
> Dr Stephen N. Henson. Email, S/MIME and PGP keys: see homepage
> OpenSSL project core developer and freelance consultant.
> Funding needed! Details on homepage.
> Homepage: http://www.drh-consultancy.demon.co.uk
> ______________________________________________________________________
> OpenSSL Project                                 http://www.openssl.org
> User Support Mailing List                    [hidden email]
> Automated List Manager                           [hidden email]
>
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: mini-ASN.1 compiler 0.9.8-dev

Dr. Stephen Henson
On Tue, May 24, 2005, pana wrote:

> I found the manual page but when I try to use the command "openssl
> asn1parse -genstr ..." the system answers me with "unknown option
> -genstr" !!
> How is it possible? bad insatallation?
>

Are you still calling the old version of OpenSSL? Check with:

openssl version

Steve.
--
Dr Stephen N. Henson. Email, S/MIME and PGP keys: see homepage
OpenSSL project core developer and freelance consultant.
Funding needed! Details on homepage.
Homepage: http://www.drh-consultancy.demon.co.uk
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: mini-ASN.1 compiler 0.9.8-dev

pana
The error exists also using openssl 0.9.8 beta2 version.
I launch the command from my home, where I've installed the OpenSSL.
Any suggestion?

bye
pana


2005/5/24, Dr. Stephen Henson <[hidden email]>:

> On Tue, May 24, 2005, pana wrote:
>
> > I found the manual page but when I try to use the command "openssl
> > asn1parse -genstr ..." the system answers me with "unknown option
> > -genstr" !!
> > How is it possible? bad insatallation?
> >
>
> Are you still calling the old version of OpenSSL? Check with:
>
> openssl version
>
> Steve.
> --
> Dr Stephen N. Henson. Email, S/MIME and PGP keys: see homepage
> OpenSSL project core developer and freelance consultant.
> Funding needed! Details on homepage.
> Homepage: http://www.drh-consultancy.demon.co.uk
> ______________________________________________________________________
> OpenSSL Project                                 http://www.openssl.org
> User Support Mailing List                    [hidden email]
> Automated List Manager                           [hidden email]
>
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]