Problems with SSL Sessions

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems with SSL Sessions

Lerchenfeld, David W.
Has anyone seen this problem I have been fighting it for some time and cannot get it resolved:
I have (specs below) Apache running on an HPUX11i server and everytime and activate SSL for a server Apache keeps launching child stacks instead of using the existing stacks.  It will eventually get to Maxstacks and freeze. It looks like a lock is set but never reset or session caching is not working.  Apache works fine when not using SSL, ANY help would be greatly appreciated...

APACHE ERROR LOGFILE:
[Tue Aug 23 21:31:44 2005] [info] Client requested a 'session-resume' but we have no such session.
[Tue Aug 23 21:31:45 2005] [info] Initial (No.1) HTTPS request received for child 0 (server netman2.mk.unisys.com:4433)
[Tue Aug 23 21:31:45 2005] [info] Connection to child 1 established (server netman2.mk.unisys.com:4433, client 172.17.8.142)
[Tue Aug 23 21:31:45 2005] [info] Seeding PRNG with 1024 bytes of entropy
[Tue Aug 23 21:31:45 2005] [info] Initial (No.1) HTTPS request received for child 1 (server netman2.mk.unisys.com:4433)
[Tue Aug 23 21:31:51 2005] [info] Connection to child 2 established (server netman2.mk.unisys.com:4433, client 172.17.8.142)
[Tue Aug 23 21:31:51 2005] [info] Seeding PRNG with 1024 bytes of entropy
[Tue Aug 23 21:31:52 2005] [info] Initial (No.1) HTTPS request received for child 2 (server netman2.mk.unisys.com:4433)
[Tue Aug 23 21:31:52 2005] [info] Connection to child 3 established (server netman2.mk.unisys.com:4433, client 172.17.8.142)
[Tue Aug 23 21:31:52 2005] [info] Seeding PRNG with 1024 bytes of entropy
[Tue Aug 23 21:31:52 2005] [info] Initial (No.1) HTTPS request received for child 3 (server netman2.mk.unisys.com:4433)
[Tue Aug 23 21:31:59 2005] [info] Connection to child 4 established (server netman2.mk.unisys.com:4433, client 172.17.8.142)
[Tue Aug 23 21:31:59 2005] [info] Seeding PRNG with 1024 bytes of entropy
[Tue Aug 23 21:31:59 2005] [info] Initial (No.1) HTTPS request received for child 4 (server netman2.mk.unisys.com:4433)
[Tue Aug 23 21:32:00 2005] [info] Connection to child 5 established (server netman2.mk.unisys.com:4433, client 172.17.8.142)
[Tue Aug 23 21:32:00 2005] [info] Seeding PRNG with 1024 bytes of entropy
[Tue Aug 23 21:32:00 2005] [info] Initial (No.1) HTTPS request received for child 5 (server netman2.mk.unisys.com:4433)
[Tue Aug 23 21:32:06 2005] [info] Connection to child 6 established (server netman2.mk.unisys.com:4433, client 172.17.8.142)
[Tue Aug 23 21:32:06 2005] [info] Seeding PRNG with 1024 bytes of entropy
[Tue Aug 23 21:32:06 2005] [info] Initial (No.1) HTTPS request received for child 6 (server netman2.mk.unisys.com:4433)

HPUX11i running Perl 5.8.4
 Apache/2.0.54 (Unix) mod_ssl/2.0.54 OpenSSL/0.9.8 DAV/2 FrontPage/5.0.2.2635 mod_perl/2.0.1 Perl/v5.8.4 configured

Dave Lerchenfeld
Thanks Lerch

     (586)354-9082

THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY MATERIAL and is thus for use only by the intended recipient. If you received this in error, please contact the sender and delete the e-mail and its attachments from all computers

______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: Problems with SSL Sessions

Richard Koenning
Lerchenfeld, David W. wrote:

> Has anyone seen this problem I have been fighting it for some time and cannot get it resolved:
> I have (specs below) Apache running on an HPUX11i server and everytime and activate SSL for a server Apache keeps launching child stacks instead of using the existing stacks.  It will eventually get to Maxstacks and freeze. It looks like a lock is set but never reset or session caching is not working.  Apache works fine when not using SSL, ANY help would be greatly appreciated...
>
> APACHE ERROR LOGFILE:
> [Tue Aug 23 21:31:44 2005] [info] Client requested a 'session-resume' but we have no such session.
> [Tue Aug 23 21:31:45 2005] [info] Initial (No.1) HTTPS request received for child 0 (server netman2.mk.unisys.com:4433)
> [...]

I don't see what this has to do with OpenSSL. Try asking the mod_ssl people.
Ciao,
Richard
--
Dr. Richard W. K├Ânning
Fujitsu Siemens Computers GmbH
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]