Problems setting up Openssl and stunnel for vnc

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Problems setting up Openssl and stunnel for vnc

Dan Cohen
Hello,

I'm new to openssl and stunnel.

I tired following http://www.securityfocus.com/infocus/1677 this web
page, and I could not get it to work.  The stunnel program would crash
/ disappear.  I have the logs and such, but I'm positive that I'm
doing something wrong.

First, are the directions on the web page
http://www.securityfocus.com/infocus/1677 accurate?

It seems that the directions generate the same private/public key pair
and certificate for the server and client?

The tutorial says to run "openssl x509" on the client and server
certificates and rename the files to the value that gets returned.  In
the tutorial, it shows different values for the two certificates, and
the commands return the same values for me.

I've tried a couple of different things.

I've used the openssl binaries found on the stunnel web site and the
capl.bat file found on the security focus website.

I've installed win32openssl and used the ca.pl script to do the same thing.

Any help would be appreciated.  I'd really like to know if the
directions and the ca.bat file on security focus website has worked
for anyone, because there seems to be very little documentation that I
can understand that would help me troubleshoot

Thanks, Dan Cohen
[hidden email]
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]