Problems installing openssl-0.9.7i on Mac OS X 10.2.8

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Problems installing openssl-0.9.7i on Mac OS X 10.2.8

Humunga Chunga
Hi folks. Repeating problem when I make openssl on my G4 Mac. Any help will
be greatly appreciated!

Thanks!

Mike

Here's the facts:

My Computer:

G4 Dual Processor, 1 Gig Ram, OS Version Mac OS X 10.2.8

using gnumake

Mac developer tools installed (but I'm not a developer - just a little
Linux/BSD self trained!)

Intend to upgrade openssh from version 3.4 to new version openssh-4.2p1, so
I am upgrading openssl first, from current version, 9.6, to openssl-0.9.7i

Problem:

./config identifies my system properly. But after make runs a while, it
exits with the following error:

+ cc -o evp_test -I.. -I../include -DOPENSSL_SYSNAME_MACOSX
-DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -DOPENSSL_NO_KRB5
-O3 -fomit-frame-pointer -DB_ENDIAN evp_test.o ../libssl.a ../libcrypto.a
ld: Undefined symbols:
_dlclose
_dlerror
_dlopen
_dlsym
make[1]: *** [evp_test] Error 1
make: *** [sub_all] Error 1
[localhost:/Downloads/openssl] root#

What I've tried:

1. Installed latest version of dlcompat. No change
2. Followed suggestions in the PROBLEM file in openssl distribution, about
the problem with Mac ld, here:

- - - - - - - - - - - -

" * System libcrypto.dylib and libssl.dylib are used by system ld on MacOS
X.


    NOTE: The problem described here only applies when OpenSSL isn't built
    with shared library support (i.e. without the "shared" configuration
    option).  If you build with shared library support, you will have no
    problems as long as you set up DYLD_LIBRARY_PATH properly at all times.


This is really a misfeature in ld, which seems to look for .dylib libraries
along the whole library path before it bothers looking for .a libraries.  
This
means that -L switches won't matter unless OpenSSL is built with shared
library support.

The workaround may be to change the following lines in apps/Makefile and
test/Makefile:

  LIBCRYPTO=-L.. -lcrypto
  LIBSSL=-L.. -lssl

to:

  LIBCRYPTO=../libcrypto.a
  LIBSSL=../libssl.a

It's possible that something similar is needed for shared library support
as well.  That hasn't been well tested yet.


Another solution that many seem to recommend is to move the libraries
/usr/lib/libcrypto.0.9.dylib, /usr/lib/libssl.0.9.dylib to a different
directory, build and install OpenSSL and anything that depends on your
build, then move libcrypto.0.9.dylib and libssl.0.9.dylib back to their
original places.  Note that the version numbers on those two libraries
may differ on your machine.


As long as Apple doesn't fix the problem with ld, this problem building
OpenSSL will remain as is."

- - - - - - -

So far no luck with any of these solutions. I get the same error with
_dlclose.

The only information I've found on the internet refers to dlcompat, and
recommends installing dlcompat from source, which I have. It also recommends
installing dlcompat-shlis, which I can not find anywhere to download.

And, the only dlcompat I found at their site on sourceforge was from 2003.
Anyone know of a newer one?

But back to the problem at hand. Any help would be greatly appreciated.

Thanks!

Mike

_________________________________________________________________
Express yourself instantly with MSN Messenger! Download today - it's FREE!
http://messenger.msn.click-url.com/go/onm00200471ave/direct/01/

______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]