OpenSSL with Qt5 on Win7

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

OpenSSL with Qt5 on Win7

Peissert, Roland (ext)

Hello,

I want to use OpenSSL with Qt5 on Win 7.

Is there any tutorial or how do or documentation, how to install and recompile OpenSSL and Qt5 on Win7 ?

 

1.       I download still install Win 7 with Visual Studio 2015

2.       Then I install Q5 with Visual Studio AddOn for Qt

3.       Next I download OpenSSL openssl-1.1.0b.tar.gz from here: http://www.openssl.org/source

4.       And I install Active Perl

5.       I made one folder C:\libsopenssl

6.       When I compile OpenSSL with this command: perl Configure VC-WIN32 no-asm –-prefix=c:\libsopenssl

7.        I receive this error:
cid:image001.png@01D2359E.43028830

 

Thank you in advanced.

 

Best Regards

Roland Peissert


--
openssl-users mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenSSL with Qt5 on Win7

Richard Moore


On 3 November 2016 at 11:59, Peissert, Roland (ext) <[hidden email]> wrote:

3.       Next I download OpenSSL openssl-1.1.0b.tar.gz from here: http://www.openssl.org/source



​Qt doesn't support openssl 1.1 currently.

Cheers

Rich.
 

--
openssl-users mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenSSL with Qt5 on Win7

Michel
In reply to this post by Peissert, Roland (ext)

Hi,

 

As nmake is not in your current path, it looks like you didn’t launch the ‘Developer Command Prompt for Visual Studio’.

 

Regards,

 

Michel.

 

 

De : openssl-users [mailto:[hidden email]] De la part de Peissert, Roland (ext)
Envoyé : jeudi 3 novembre 2016 12:59
À : [hidden email]
Objet : [openssl-users] OpenSSL with Qt5 on Win7

 

Hello,

I want to use OpenSSL with Qt5 on Win 7.

Is there any tutorial or how do or documentation, how to install and recompile OpenSSL and Qt5 on Win7 ?

 

1.       I download still install Win 7 with Visual Studio 2015

2.       Then I install Q5 with Visual Studio AddOn for Qt

3.       Next I download OpenSSL openssl-1.1.0b.tar.gz from here: http://www.openssl.org/source

4.       And I install Active Perl

5.       I made one folder C:\libsopenssl

6.       When I compile OpenSSL with this command: perl Configure VC-WIN32 no-asm –-prefix=c:\libsopenssl

7.        I receive this error:
cid:image001.png@01D2359E.43028830

 

Thank you in advanced.

 

Best Regards

Roland Peissert


--
openssl-users mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenSSL with Qt5 on Win7

Kim Gräsman
In reply to this post by Peissert, Roland (ext)
On Thu, Nov 3, 2016 at 2:02 PM, Michel <[hidden email]> wrote:

Hi,

 

As nmake is not in your current path, it looks like you didn’t launch the ‘Developer Command Prompt for Visual Studio’.

 



For posterity, I've gotten that message even when nmake is on the path. Invoking nmake afterwards works fine.

- Kim

--
openssl-users mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenSSL with Qt5 on Win7

Matt Caswell-2


On 03/11/16 13:14, Kim Gräsman wrote:

> On Thu, Nov 3, 2016 at 2:02 PM, Michel <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     Hi,____
>
>     __ __
>
>     As nmake is not in your current path, it looks like you didn’t
>     launch the ‘Developer Command Prompt for Visual Studio’.____
>
>     __ __
>
>
>
> For posterity, I've gotten that message even when nmake is on the path.
> Invoking nmake afterwards works fine.

It comes from perl not OpenSSL. I'm not sure why - some problem in the
perl setup I think.

Matt

--
openssl-users mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-users