OpenSSL and GOST engine issue (statically linked library )

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

OpenSSL and GOST engine issue (statically linked library )

Abyss Lingvo
I have added OpenSSL_add_all_algorithms(); function call to initialization part but without success.
The same behavior as before.

What's more for dynamically linked version it works without OpenSSL_add_all_algorithms() call. 



 

Reply | Threaded
Open this post in threaded view
|

Re: OpenSSL and GOST engine issue (statically linked library )

Andrey Koltsov-2
Do you have following sections in you openssl.cnf file?

[openssl_def]
engines = engine_section

[engine_section]
gost = gost_section

[gost_section]
engine_id = gost
default_algorithms = ALL
CRYPT_PARAMS = id-Gost28147-89-CryptoPro-A-ParamSet

There should not be any dynamic_path parameter in gost_section.


Best regards,

Andrey Koltsov
software developer


14.06.2012 15:25, Abyss Lingvo написал:

> I have added OpenSSL_add_all_algorithms(); function call to initialization part but without success.
> The same behavior as before.
>
> What's more for dynamically linked version it works without OpenSSL_add_all_algorithms() call.
>
>
>
>
>
>
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]
Reply | Threaded
Open this post in threaded view
|

OpenSSL and GOST engine issue (statically linked library )

Abyss Lingvo
>>Do you have following sections in you openssl.cnf file?

Yes I have these sections in my openssl.cnf, and no dynamic_path parameter. 
It happens only if I use static linkage (with libssl.a and libcrypto.a) .
If I use dynamic linkage with openssl (with libssl.so and libcrypto.so) everything works fine.

 
От: Andrey Koltsov <[hidden email]>
Кому: "[hidden email]" <[hidden email]>
Отправлено: четверг, 14 июня 2012 16:40
Тема: Re: OpenSSL and GOST engine issue (statically linked library )

Do you have following sections in you openssl.cnf file?

[openssl_def]
engines = engine_section

[engine_section]
gost = gost_section

[gost_section]
engine_id = gost
default_algorithms = ALL
CRYPT_PARAMS = id-Gost28147-89-CryptoPro-A-ParamSet

There should not be any dynamic_path parameter in gost_section.


Best regards,

Andrey Koltsov
software developer


14.06.2012 15:25, Abyss Lingvo написал:

> I have added OpenSSL_add_all_algorithms(); function call to initialization part but without success.
> The same behavior as before.
>
> What's more for dynamically linked version it works without OpenSSL_add_all_algorithms() call.
>
>
>
>
>
>
______________________________________________________________________
OpenSSL Project                                http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                          [hidden email]