OpenSSL 0.9.8 compatibility

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

OpenSSL 0.9.8 compatibility

prakash babu
Hello all,
 
I have a  few clarifications regarding  OpenSSL  0.9.8's compatibility
 
1. Is OpenSSL 0.9.8 compatible with 0.9.7 (i.e) will all the existing applications
written for 0.9.7 will continue to work with 0.9.8 without any source code changes  ?
2. Does 0.9.8 have all the functionality of 0.9.7 ?
 
Your response to these questions will help me choose the appropriate version of OpenSSL
 
Thanks,
Prakash


Yahoo! for Good
Click here to donate to the Hurricane Katrina relief effort.
Reply | Threaded
Open this post in threaded view
|

RE: OpenSSL 0.9.8 compatibility

Frédéric Donnat-2
Hi,

It depends on what you mean by compatible!

For example, 0.9.7 has a FIPS part that is not in 0.9.8 (for now).
SHA-256 are part of openssl 0.9.8, whereas it is only in the FIPS module of 0.9.7.
Also have a look at RSA structure change in 0.9.8 (ENGINE have changed too).

You should have a look at the CHANGES file to see if "your code" is impacted by the changes.

regards.

Fred.

-----Original Message-----
From: prakash babu [mailto:[hidden email]]
Sent: Sat 10/1/2005 6:05 AM
To: [hidden email]
Cc: [hidden email]
Subject: OpenSSL 0.9.8 compatibility
Hello all,
 
I have a  few clarifications regarding  OpenSSL  0.9.8's compatibility
 
1. Is OpenSSL 0.9.8 compatible with 0.9.7 (i.e) will all the existing applications
written for 0.9.7 will continue to work with 0.9.8 without any source code changes  ?
2. Does 0.9.8 have all the functionality of 0.9.7 ?
 
Your response to these questions will help me choose the appropriate version of OpenSSL
 
Thanks,
Prakash

               
---------------------------------
Yahoo! for Good
 Click here to donate to the Hurricane Katrina relief effort.


______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]
Reply | Threaded
Open this post in threaded view
|

RE: OpenSSL 0.9.8 compatibility

pradeep susarla
In reply to this post by prakash babu
Hi,,

             Basically I am a newbie to openssl. but unable to understand
which version to  implement.  Can you tell me where to find openssl source
code? where to get the libcrypto.so.4 files?

~Pradeep.


______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]