Intermittent ssl errors without OPENSSL_ia32cap

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Intermittent ssl errors without OPENSSL_ia32cap

abel alejandro
Hello all,

I have a AMD 3600x + X470D4U system where I observed intermittent ssl
problems including data corruption of files when downloading thru
https.

For example:

root@oasis:~#  curl -o o https://www.google.com
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
curl: (35) error:1408F119:SSL routines:ssl3_get_record:decryption
failed or bad record mac
root@oasis:~#

This was originally on unraid linux distribution but I also tried Slax
live with the same results.

At the end I was able to get rid of the warnings and download without
data corruption by using OPENSSL_ia32cap="~0x200000200000000". Could
this be a bug somewhere in openssl or my hardware is just bad?

Thanks!
Reply | Threaded
Open this post in threaded view
|

Re: Intermittent ssl errors without OPENSSL_ia32cap

Matt Caswell-2


On 13/05/2020 02:14, abel alejandro wrote:
> At the end I was able to get rid of the warnings and download without
> data corruption by using OPENSSL_ia32cap="~0x200000200000000". Could
> this be a bug somewhere in openssl or my hardware is just bad?

It could be a bug. I suggest you raise a github issue about it. Please
include details about the version of OpenSSL being used.

Matt