Integrate EVP Cipher into OpenSSL cli Speed Test

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Integrate EVP Cipher into OpenSSL cli Speed Test

Schmicker, Robert

Hello,


I successfully managed to integrate an encryption cipher into the EVP and has been

tested to work and now I'd like to get some speed tests of the cipher using openssl's

integrated speed test via the command line with the "-evp" flag.


What I've done so far to try and integrate it into openssl's speed test....


1) Confirmed EVP_mycipher() works


2) Noticed ./apps/speed.c was calling:

         case OPT_EVP:

                         evp_cipher = EVP_get_cipherbyname(opt_arg());

3) Then modified ./crypto/objects/objects.txt to include the necessary defines
         # Mycipher
                       : MYCIPHER             : mycipher

4) Edited crypto/evp/c_allc.c to include my cipher in the loading of all ciphers

EVP_add_cipher(EVP_mycipher());
EVP_add_cipher_alias(SN_mycipher, "mycipher");

5) Ran a make update then make and saw all necessary defines were generated

However, the speed test cannot find my cipher because EVP_get_cipherbyname()
returns NULL.

Am I missing a step here or did I mis-configure something?

It seems as if there's something to edit to tie the NID/SN/LN_mycipher to the algorithm.

Any help is much appreciated!

Rob Schmicker


--
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Integrate EVP Cipher into OpenSSL cli Speed Test

Short, Todd
Look at some of the changes to pull in Poly1305 and SipHash in to EVP:


--
-Todd Short
// "One if by land, two if by sea, three if by the Internet."

On Feb 22, 2017, at 11:00 PM, Schmicker, Robert <[hidden email]> wrote:

Hello,

I successfully managed to integrate an encryption cipher into the EVP and has been 
tested to work and now I'd like to get some speed tests of the cipher using openssl's 
integrated speed test via the command line with the "-evp" flag.

What I've done so far to try and integrate it into openssl's speed test....

1) Confirmed EVP_mycipher() works

2) Noticed ./apps/speed.c was calling:
         case OPT_EVP: 
                         evp_cipher = EVP_get_cipherbyname(opt_arg());

3) Then modified ./crypto/objects/objects.txt to include the necessary defines
         # Mycipher
                       : MYCIPHER             : mycipher

4) Edited crypto/evp/c_allc.c to include my cipher in the loading of all ciphers

EVP_add_cipher(EVP_mycipher());
EVP_add_cipher_alias(SN_mycipher, "mycipher");

5) Ran a make update then make and saw all necessary defines were generated

However, the speed test cannot find my cipher because EVP_get_cipherbyname()
returns NULL. 

Am I missing a step here or did I mis-configure something?

It seems as if there's something to edit to tie the NID/SN/LN_mycipher to the algorithm.

Any help is much appreciated!

Rob Schmicker

-- 
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev


--
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Integrate EVP Cipher into OpenSSL cli Speed Test

Schmicker, Robert

Thanks! The moment after I sent that original email I realized in my infinite wisdom that I originally hard coded the NID value in my EVP implementation to get some testing to work. I then never went back and changed it to the define value...

Regardless, thank you for the help.

Rob

From: Short, Todd
Sent: Thursday, February 23, 8:29 AM
Subject: Re: [openssl-dev] Integrate EVP Cipher into OpenSSL cli Speed Test
To: [hidden email], Schmicker, Robert

Look at some of the changes to pull in Poly1305 and SipHash in to EVP:

https://github.com/openssl/openssl/commit/52ad5b60e3a1fef12a1a5ea01527a90b8f92a34b

https://github.com/openssl/openssl/commit/3f5616d734a92fdf99ab827f21e5b6cab85e7194

--

-Todd Short

// [hidden email][hidden email]

// "One if by land, two if by sea, three if by the Internet."

On Feb 22, 2017, at 11:00 PM, Schmicker, Robert <[hidden email][hidden email]> wrote:

Hello,

I successfully managed to integrate an encryption cipher into the EVP and has been 

tested to work and now I'd like to get some speed tests of the cipher using openssl's 

integrated speed test via the command line with the "-evp" flag.

What I've done so far to try and integrate it into openssl's speed test....

1) Confirmed EVP_mycipher() works

2) Noticed ./apps/speed.c was calling:

         case OPT_EVP: 

                         evp_cipher = EVP_get_cipherbyname(opt_arg());

3) Then modified ./crypto/objects/objects.txt to include the necessary defines

         # Mycipher
                       : MYCIPHER             : mycipher

4) Edited crypto/evp/c_allc.c to include my cipher in the loading of all ciphers

EVP_add_cipher(EVP_mycipher());
EVP_add_cipher_alias(SN_mycipher, "mycipher");

5) Ran a make update then make and saw all necessary defines were generated

However, the speed test cannot find my cipher because EVP_get_cipherbyname()
returns NULL. 

Am I missing a step here or did I mis-configure something?

It seems as if there's something to edit to tie the NID/SN/LN_mycipher to the algorithm.

Any help is much appreciated!

Rob Schmicker

-- 
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev




--
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
Loading...