Fips lib usage in Openssl 1.1.1

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Fips lib usage in Openssl 1.1.1

Manish Patidar
Hi

I want to use fips certify crypto libs. Is it possible to use crypto lib from  Openssl-fips 2.0.16 and  ssl lib from Openssl1.1.1? 
If yes, how we can use, pleas provide details? 

Regards 
Manish



--
openssl-users mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-users
Reply | Threaded
Open this post in threaded view
|

Re: Fips lib usage in Openssl 1.1.1

OpenSSL - User mailing list
  • I want to use fips certify crypto libs. Is it possible to use crypto lib from  Openssl-fips 2.0.16 and  ssl lib from Openssl1.1.1?

 

No, it is not possible.  The current FIPS code only works with 1.0.2.  The project is working on a new FIPS module.  You can find some details at the blog, https://www.openssl.org/blog/


--
openssl-users mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-users