Dynamic Engines on Mac OS X

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Dynamic Engines on Mac OS X

Christopher P. Masone
Hi, all.  I've been trying to get dynamic engine support working on OS X for
about a week now, and no luck.  My goal is to use the opensc pkcs11 engine with
openssl, so I can use an aladdin etoken.  I've got OpenSSL 0.9.8 05 Jul 2005,
according to openssl version.  I configure openssl like this when I build it:

./config -DENGINE_DYNAMIC_SUPPORT shared

I've tried some other flags (-DSO_DLFCN doesn't help, -DDSO_DLFCN makes the
build fail) as well, based on info I found poking around the openssl list, BSD
lists, and some other places, but I still get the same error.  I also tried
using one of the engines that comes with openssl, so I could exclude the
possibility of doing something wrong in the opensc build process.  I run the
following command from the install directory, /usr/local/ssl/:
 
bin/openssl engine -vvvv dynamic -pre
SO_PATH:/usr/local/ssl/lib/engines/lib4758cca.so -pre LOAD

and I get this output:

(dynamic) Dynamic engine loading support
[Success]: SO_PATH:/usr/local/ssl/lib/engines/lib4758cca.so
[Failure]: LOAD
26743:error:2507006C:DSO support routines:DSO_load:functionality not
supported:dso_lib.c:239:
26743:error:260B6084:engine routines:DYNAMIC_LOAD:dso not found:eng_dyn.c:450:

Going through the code, it looks like there's just no installed method for
loading DSOs...what can I do?  Is this functionality truly unsupported on OS X,
or am I just not building properly?

Thanks,
Chris Masone
______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]