Crypt::SSLeay build problem

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Crypt::SSLeay build problem

Richard Proctor-2
Hi,

Crypt::SSLeay build problem

I run a Cobalt RaQ4 server that has a number of sites.  I need to twesk the
(perl) shopping suite of one of the users so it works with a credit card
company.  To do this it needs to send https messages.  The server can happily
recieve https.

The system (built on RedHat) has a built in partial installation of openssl,
(without libraries), that is not enough to allow my to install
Crypt::SSLeay.  

I have built a new complete version in another place, so as not to disturb
the existing use of the built in version.

I then built and tried to test Crypt::SSLeay which resulted in errors.

*** Log of building Crypt::SSLeay

[root Crypt-SSLeay-0.51]# perl Makefile.PL
No OpenSSL installation found, usually in /usr/local/openssl
Which OpenSSL build path do you want to link against?  /wws/bin

================================================
BUILD INFORMATION
================================================

ssl dir:        /wws/bin
libraries:      -lssl -lcrypto -lgcc -lRSAglue -lrsaref
include dir:    /wws/bin/include
ssl header:     openssl/ssl.h
ssl candidate:  /wws/bin; /wws/bin/include/openssl; OpenSSL 0.9.8

================================================

Note (probably harmless): No library found for -lgcc
Note (probably harmless): No library found for -lRSAglue
Note (probably harmless): No library found for -lrsaref
Writing Makefile for Crypt::SSLeay

*** Log of building Crypt::SSLeay
[root Crypt-SSLeay-0.51]# make
cc -c -I/wws/bin/include -Dbool=char -DHAS_BOOL -I/usr/local/include -O2    -DVE
RSION=\"0.51\" -DXS_VERSION=\"0.51\" -fpic -I/usr/lib/perl5/5.00503/i386-linux/C
ORE  SSLeay.c
SSLeay.xs: In function `XS_Crypt__SSLeay__Conn_new':
SSLeay.xs:252: warning: passing arg 2 of `SSL_set_info_callback' from incompatib
le pointer type
Running Mkbootstrap for Crypt::SSLeay ()
chmod 644 SSLeay.bs
LD_RUN_PATH="/wws/bin/lib" cc -o blib/arch/auto/Crypt/SSLeay/SSLeay.so  -shared
-L/usr/local/lib SSLeay.o    -L/wws/bin/lib -lssl -lcrypto
chmod 755 blib/arch/auto/Crypt/SSLeay/SSLeay.so
cp SSLeay.bs blib/arch/auto/Crypt/SSLeay/SSLeay.bs
chmod 644 blib/arch/auto/Crypt/SSLeay/SSLeay.bs
Manifying blib/man3/Crypt::SSLeay.3

*** Log of testing Crypt::SSLeay

[root Crypt-SSLeay-0.51]# make test
PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib -I/usr/lib/perl5/5.00503/
i386-linux -I/usr/lib/perl5/5.00503 -e 'use Test::Harness qw(&runtests $verbose)
; $verbose=0; runtests @ARGV;' t/*.t
t/net_ssl...........dubious
        Test returned status 0 (wstat 11, 0xb)
Undefined subroutine &Test::Harness::WCOREDUMP called at /usr/lib/perl5/5.00503/
Test/Harness.pm line 288.
make: *** [test_dynamic] Error 255

What is wrong, how do I fix it?

Thanks.

Richard



--
Personal     [hidden email]            http://www.waveney.org
Telecoms     [hidden email]  http://www.WaveneyConsulting.com
Web services [hidden email]            http://www.wavwebs.com
Independent Telecomms Specialist, ATM expert, Web Analyst & Services

______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [hidden email]
Automated List Manager                           [hidden email]