Compile For WinCE problem...

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view

Compile For WinCE problem...


OK I figured out what I did wrong and now it works OK:


To fix…

-I downloaded

-I cd to C:\wcecompat and run nmake

I  set WCECOMPAT=C:\wcecompat


Many thanks to the people at Pervasive Computing ( where I got the info and Portable OpenSSL src to use here!


-----Original Message-----
From: owner-
[hidden email] [mailto:owner-[hidden email]] On Behalf Of OpenSSLGRT
Wednesday, February 08, 2006 10:43 AM
[hidden email]
Subject: Compile For WinCE problem...


I tried to compile OpenSSL 0.9.8a for Windows CE but I get errors saying many include files are missing.

Can someone say if the below steps are correct or help solve errors – thank you!:


I used Pervasive Computing’s OpenSSL files


-downloaded src from

-downloaded and extracted to c:\wce_lite_compat

-C:\Program Files\Microsoft eMbedded C++ 4.0\EVC\wce420\bin\WCEARMV4.BAT

-set WCECOMPAT=C:\wce_lite_compat


-cd C:\myprojects\opensslpda\openssl-0.9.8a

--perl Configure VC-CE

(this worked ok)


C:\myprojects\opensslpda\openssl-0.9.8a>perl Configure VC-CE

(this worked OK -- said “Configured for VC-CE.”)



(this worked OK)


To setup my command line environment I copied the wce420 dir from C:\Program Files\Windows CE Tools\ to C:\Windows CE Tools

From DOS window I see that my INCLUDE vars point to:


C:\Windows CE Tools\WCE420\POCKET PC 2003\include\ARMV4;

C:\Windows CE Tools\WCE420\POCKET PC 2003\MFC\include;

C:\Windows CE Tools\WCE420\POCKET PC 2003\ATL\include;


C:\myprojects\opensslpda\openssl-0.9.8a>nmake -f ms\cedll.mak


Microsoft (R) Program Maintenance Utility   Version 6.00.8168.0

Copyright (C) Microsoft Corp 1988-1998. All rights reserved.


Building OpenSSL

clarm.exe /Fotmp32dll\cryptlib.obj  -Iinc32 -Itmp32dll /MC /O1i /W3 /WX


AN -DL_ENDIAN -DDSO_WIN32 -DNO_CHMOD -IC:\wce_lite_compat/include -DOPENSSL_SMAL





c:\myprojects\opensslpda\openssl-0.9.8a\tmp32dll\e_os.h(267) : fatal error C1083

: Cannot open include file: 'errno.h': No such file or directory

NMAKE : fatal error U1077: 'clarm.exe' : return code '0x2'