CRYPTO_mem_leaks Error in openssl 1.1.1d

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

CRYPTO_mem_leaks Error in openssl 1.1.1d

shiva kumar
Hi, 
I'm trying to use the CRYPTO_mem_leaks  API in openssl 1.1.1d, but during compilation I'm getting error as 
Unsatisfied symbol "CRYPTO_mem_leaks" 

I have Included the header 
#include <openssl/crypto.h>

one doubt is it is defined under crypto.h
#ifndef OPENSSL_NO_CRYPTO_MDEBUG
CRYPTO_mem_leaks //  defined
#endif 

in opensslconf.h is defined as  
#ifndef OPENSSL_NO_CRYPTO_MDEBUG
#define OPENSSL_NO_CRYPTO_MDEBUG
#endif 

How to resolve the issue?
please help me

Regards
Shivakumar
Reply | Threaded
Open this post in threaded view
|

Re: CRYPTO_mem_leaks Error in openssl 1.1.1d

Matt Caswell-2


On 10/11/2020 09:19, shiva kumar wrote:

> Hi, 
> I'm trying to use the CRYPTO_mem_leaks  API in openssl 1.1.1d, but
> during compilation I'm getting error as 
> *Unsatisfied symbol "CRYPTO_mem_leaks" *
>
> I have Included the header 
> #include <openssl/crypto.h>
>
> one doubt is it is defined under crypto.h
> #ifndef OPENSSL_NO_CRYPTO_MDEBUG
> CRYPTO_mem_leaks //  defined
> #endif 
>
> in opensslconf.h is defined as  
> #ifndef OPENSSL_NO_CRYPTO_MDEBUG
> #define OPENSSL_NO_CRYPTO_MDEBUG
> #endif 
>
> How to resolve the issue?

The CRYPTO_mem_leaks API is not available by default. You have to
compile a version of OpenSSL that has it enabled using the
"enable-crypto-mdebug" option to "Configure":

https://github.com/openssl/openssl/blob/6e933b35492a4dc3370b9f49890646dadca82cd8/INSTALL#L327-L329

Matt

Reply | Threaded
Open this post in threaded view
|

Re: CRYPTO_mem_leaks Error in openssl 1.1.1d

shiva kumar
Any alternatives for this, if the compiled version doesn't enabled the flag?

On Tue, 10 Nov 2020 at 4:52 PM, Matt Caswell <[hidden email]> wrote:


On 10/11/2020 09:19, shiva kumar wrote:
> Hi, 
> I'm trying to use the CRYPTO_mem_leaks  API in openssl 1.1.1d, but
> during compilation I'm getting error as 
> *Unsatisfied symbol "CRYPTO_mem_leaks" *
>
> I have Included the header 
> #include <openssl/crypto.h>
>
> one doubt is it is defined under crypto.h
> #ifndef OPENSSL_NO_CRYPTO_MDEBUG
> CRYPTO_mem_leaks //  defined
> #endif 
>
> in opensslconf.h is defined as  
> #ifndef OPENSSL_NO_CRYPTO_MDEBUG
> #define OPENSSL_NO_CRYPTO_MDEBUG
> #endif 
>
> How to resolve the issue?

The CRYPTO_mem_leaks API is not available by default. You have to
compile a version of OpenSSL that has it enabled using the
"enable-crypto-mdebug" option to "Configure":

https://github.com/openssl/openssl/blob/6e933b35492a4dc3370b9f49890646dadca82cd8/INSTALL#L327-L329

Matt

--
With Best Regards
Shivakumar S
Reply | Threaded
Open this post in threaded view
|

Re: CRYPTO_mem_leaks Error in openssl 1.1.1d

Matt Caswell-2


On 10/11/2020 13:25, shiva kumar wrote:
> Any alternatives for this, if the compiled version doesn't enabled the flag?

valgrind?


Matt

>
> On Tue, 10 Nov 2020 at 4:52 PM, Matt Caswell <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>
>
>     On 10/11/2020 09:19, shiva kumar wrote:
>     > Hi, 
>     > I'm trying to use the CRYPTO_mem_leaks  API in openssl 1.1.1d, but
>     > during compilation I'm getting error as 
>     > *Unsatisfied symbol "CRYPTO_mem_leaks" *
>     >
>     > I have Included the header 
>     > #include <openssl/crypto.h>
>     >
>     > one doubt is it is defined under crypto.h
>     > #ifndef OPENSSL_NO_CRYPTO_MDEBUG
>     > CRYPTO_mem_leaks //  defined
>     > #endif 
>     >
>     > in opensslconf.h is defined as  
>     > #ifndef OPENSSL_NO_CRYPTO_MDEBUG
>     > #define OPENSSL_NO_CRYPTO_MDEBUG
>     > #endif 
>     >
>     > How to resolve the issue?
>
>     The CRYPTO_mem_leaks API is not available by default. You have to
>     compile a version of OpenSSL that has it enabled using the
>     "enable-crypto-mdebug" option to "Configure":
>
>     https://github.com/openssl/openssl/blob/6e933b35492a4dc3370b9f49890646dadca82cd8/INSTALL#L327-L329
>
>     Matt
>
> --
> *With Best Regards*
> *Shivakumar S*
Reply | Threaded
Open this post in threaded view
|

Re: CRYPTO_mem_leaks Error in openssl 1.1.1d

shiva kumar
Can you please provide me examples or links to refer it.

On Tue, 10 Nov 2020 at 7:04 PM, Matt Caswell <[hidden email]> wrote:


On 10/11/2020 13:25, shiva kumar wrote:
> Any alternatives for this, if the compiled version doesn't enabled the flag?

valgrind?


Matt

>
> On Tue, 10 Nov 2020 at 4:52 PM, Matt Caswell <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>
>
>     On 10/11/2020 09:19, shiva kumar wrote:
>     > Hi, 
>     > I'm trying to use the CRYPTO_mem_leaks  API in openssl 1.1.1d, but
>     > during compilation I'm getting error as 
>     > *Unsatisfied symbol "CRYPTO_mem_leaks" *
>     >
>     > I have Included the header 
>     > #include <openssl/crypto.h>
>     >
>     > one doubt is it is defined under crypto.h
>     > #ifndef OPENSSL_NO_CRYPTO_MDEBUG
>     > CRYPTO_mem_leaks //  defined
>     > #endif 
>     >
>     > in opensslconf.h is defined as  
>     > #ifndef OPENSSL_NO_CRYPTO_MDEBUG
>     > #define OPENSSL_NO_CRYPTO_MDEBUG
>     > #endif 
>     >
>     > How to resolve the issue?
>
>     The CRYPTO_mem_leaks API is not available by default. You have to
>     compile a version of OpenSSL that has it enabled using the
>     "enable-crypto-mdebug" option to "Configure":
>
>     https://github.com/openssl/openssl/blob/6e933b35492a4dc3370b9f49890646dadca82cd8/INSTALL#L327-L329
>
>     Matt
>
> --
> *With Best Regards*
> *Shivakumar S*
--
With Best Regards
Shivakumar S
Reply | Threaded
Open this post in threaded view
|

Re: CRYPTO_mem_leaks Error in openssl 1.1.1d

Matt Caswell-2


On 10/11/2020 13:37, shiva kumar wrote:
> Can you please provide me examples or links to refer it.

Google is your friend here.

https://valgrind.org/

The above site has a quick start guide which should help.

Matt


>
> On Tue, 10 Nov 2020 at 7:04 PM, Matt Caswell <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>
>
>     On 10/11/2020 13:25, shiva kumar wrote:
>     > Any alternatives for this, if the compiled version doesn't enabled
>     the flag?
>
>     valgrind?
>
>
>     Matt
>
>     >
>     > On Tue, 10 Nov 2020 at 4:52 PM, Matt Caswell <[hidden email]
>     <mailto:[hidden email]>
>     > <mailto:[hidden email] <mailto:[hidden email]>>> wrote:
>     >
>     >
>     >
>     >     On 10/11/2020 09:19, shiva kumar wrote:
>     >     > Hi, 
>     >     > I'm trying to use the CRYPTO_mem_leaks  API in openssl
>     1.1.1d, but
>     >     > during compilation I'm getting error as 
>     >     > *Unsatisfied symbol "CRYPTO_mem_leaks" *
>     >     >
>     >     > I have Included the header 
>     >     > #include <openssl/crypto.h>
>     >     >
>     >     > one doubt is it is defined under crypto.h
>     >     > #ifndef OPENSSL_NO_CRYPTO_MDEBUG
>     >     > CRYPTO_mem_leaks //  defined
>     >     > #endif 
>     >     >
>     >     > in opensslconf.h is defined as  
>     >     > #ifndef OPENSSL_NO_CRYPTO_MDEBUG
>     >     > #define OPENSSL_NO_CRYPTO_MDEBUG
>     >     > #endif 
>     >     >
>     >     > How to resolve the issue?
>     >
>     >     The CRYPTO_mem_leaks API is not available by default. You have to
>     >     compile a version of OpenSSL that has it enabled using the
>     >     "enable-crypto-mdebug" option to "Configure":
>     >
>     >   
>      https://github.com/openssl/openssl/blob/6e933b35492a4dc3370b9f49890646dadca82cd8/INSTALL#L327-L329
>     >
>     >     Matt
>     >
>     > --
>     > *With Best Regards*
>     > *Shivakumar S*
>
> --
> *With Best Regards*
> *Shivakumar S*