Building openssh7.9p1 and above against openssl1.1.1b

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Building openssh7.9p1 and above against openssl1.1.1b

OpenSSL - User mailing list
Hi,

After upgrading openssl to 1.1.1b, I am getting compilation errors in the openssh code.

Does Openssh 7.9p1 and above versions support building against the openssl 1.1.1b version?
In Openssh release notes, below note is mentioned:
All: support building against the openssl-1.1 API (releases 1.1.0g
   and later). The openssl-1.0 API will remain supported at least
   until OpenSSL terminates security patch support for that API version.
Does this mean it is supported?
Thanks & Regards,
Samiya khanum
Reply | Threaded
Open this post in threaded view
|

AW: Building openssh7.9p1 and above against openssl1.1.1b

Dr. Matthias St. Pierre

If the compilation errors are in openssh, then it might be better to ask the openssh people.

Also, posting the precise error messages by the compiler would be of great help.

As for your citation below: It seems to state that building against version 1.1.0 and 1.1.1 is supported,

while building against version 1.0.2 will be supported until it is end-of-life, which is by the end of this year.

 

HTH,

Matthias

 

 

Von: openssl-users <[hidden email]> Im Auftrag von Samiya Khanum via openssl-users
Gesendet: Mittwoch, 15. Mai 2019 04:55
An: [hidden email]
Betreff: Building openssh7.9p1 and above against openssl1.1.1b

 

Hi,

 

After upgrading openssl to 1.1.1b, I am getting compilation errors in the openssh code.

 

Does Openssh 7.9p1 and above versions support building against the openssl 1.1.1b version?

In Openssh release notes, below note is mentioned:

All: support building against the openssl-1.1 API (releases 1.1.0g
   and later). The openssl-1.0 API will remain supported at least
   until OpenSSL terminates security patch support for that API version.
Does this mean it is supported?

Thanks & Regards,

Samiya khanum