1.1-pre3 configuration changes

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

1.1-pre3 configuration changes

Erik Forsberg-11

OK, now I'm confused, in pre2 I started using personal .conf
files with my specific build configuration, that no longer works in pre3

If I do the same as before, I copied my conf file into Configurations
subdirectory then ran make -f Makefile.in TABLE to generate a new TABLE
file containing my configuration among all other configs. Then I ran
a normal Configure

Doing that with pre3, make TABLE bombs out because the Makefile.in file
has stuff in it that must be processed by perl first (line 33 is first case)

How should I update the TABLE file in pre3 ?
--
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
Reply | Threaded
Open this post in threaded view
|

Re: 1.1-pre3 configuration changes

Richard Levitte - VMS Whacker-2
In message <[hidden email]> on Mon, 15 Feb 2016 14:30:48 -0800, "Erik Forsberg" <[hidden email]> said:

erik>
erik> OK, now I'm confused, in pre2 I started using personal .conf
erik> files with my specific build configuration, that no longer works in pre3
erik>
erik> If I do the same as before, I copied my conf file into Configurations
erik> subdirectory then ran make -f Makefile.in TABLE to generate a new TABLE
erik> file containing my configuration among all other configs. Then I ran
erik> a normal Configure
erik>
erik> Doing that with pre3, make TABLE bombs out because the Makefile.in file
erik> has stuff in it that must be processed by perl first (line 33 is first case)
erik>
erik> How should I update the TABLE file in pre3 ?

Some changes have been made, it's true.  Would you mind letting me
have a look at your .conf file to see for myself?

--
Richard Levitte         [hidden email]
OpenSSL Project         http://www.openssl.org/~levitte/
--
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
Reply | Threaded
Open this post in threaded view
|

Re: 1.1-pre3 configuration changes

Erik Forsberg-11
Sure, attached.
However, dont think anything wrong with it, I did notice the changes
and aligned. The question is more how do I incorporate my custom conf file into
the build system. Copying this conf file into Configrations and running
make -f Makefile.in TABLE
results in this

+ cp ../20-efca.conf Configurations
+ make -f Makefile.in TABLE
make: Fatal error in reader: Makefile.in, line 33: Badly formed macro assignment

GNU make throws a differently worded error on same line.

If I manually run
perl Configure TABLE > TABLE
it works OK, at least I can run Configure

Another bug is that with pre3, assembler support is broken for solaris64-x86_64-cc
configurations. First assembler file x86_64cpuid.pl gets tons of syntax errors.
Havent looked too deep yet. Has been working fine for ever.

My platform is Solaris 11 x64 using native SunStudio btw
Will try gcc too.

>-- Original Message --
>
>In message <[hidden email]> on Mon, 15 Feb 2016 14:30:48 -0800, "Erik Forsberg" <[hidden email]> said:
>
>erik>
>erik> OK, now I'm confused, in pre2 I started using personal .conf
>erik> files with my specific build configuration, that no longer works in pre3
>erik>
>erik> If I do the same as before, I copied my conf file into Configurations
>erik> subdirectory then ran make -f Makefile.in TABLE to generate a new TABLE
>erik> file containing my configuration among all other configs. Then I ran
>erik> a normal Configure
>erik>
>erik> Doing that with pre3, make TABLE bombs out because the Makefile.in file
>erik> has stuff in it that must be processed by perl first (line 33 is first case)
>erik>
>erik> How should I update the TABLE file in pre3 ?
>
>Some changes have been made, it's true.  Would you mind letting me
>have a look at your .conf file to see for myself?
>
>--
>Richard Levitte         [hidden email]
>OpenSSL Project         http://www.openssl.org/~levitte/
>--
>openssl-dev mailing list
>To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev

--
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev

20-efca.conf (2K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: 1.1-pre3 configuration changes

Richard Levitte - VMS Whacker-2
In message <[hidden email]> on Mon, 15 Feb 2016 15:02:52 -0800, "Erik Forsberg" <[hidden email]> said:

erik> Sure, attached.
erik> However, dont think anything wrong with it, I did notice the changes
erik> and aligned. The question is more how do I incorporate my custom conf file into
erik> the build system. Copying this conf file into Configrations and running
erik> make -f Makefile.in TABLE
erik> results in this
erik>
erik> + cp ../20-efca.conf Configurations
erik> + make -f Makefile.in TABLE
erik> make: Fatal error in reader: Makefile.in, line 33: Badly formed macro assignment

Ah-ha!  Using Makefile.in directly like that is not possible any
more.  The reason is that we've templatised it.  If you look, you'll
see that there are perl fragments within {- and -} delimiters.  Line
33 is right in the middle of one of those.

The answer is that you MUST configure first.  We could probably
clarify that a bit louder (and when I'm looking in INSTALL right now,
I'm noticing it's lagging behind on the changes.  To be fixed!)

erik> GNU make throws a differently worded error on same line.

Yup.  The answer will remain "don't do that, configure first!"

erik> If I manually run
erik> perl Configure TABLE > TABLE
erik> it works OK, at least I can run Configure

Yes.

erik> Another bug is that with pre3, assembler support is broken for solaris64-x86_64-cc
erik> configurations. First assembler file x86_64cpuid.pl gets tons of syntax errors.
erik> Havent looked too deep yet. Has been working fine for ever.

Ok, that's to look into.  Mind giving us a log?

erik> My platform is Solaris 11 x64 using native SunStudio btw
erik> Will try gcc too.
erik>
erik> >-- Original Message --
erik> >
erik> >In message <[hidden email]> on Mon, 15 Feb 2016 14:30:48 -0800, "Erik Forsberg" <[hidden email]> said:
erik> >
erik> >erik>
erik> >erik> OK, now I'm confused, in pre2 I started using personal .conf
erik> >erik> files with my specific build configuration, that no longer works in pre3
erik> >erik>
erik> >erik> If I do the same as before, I copied my conf file into Configurations
erik> >erik> subdirectory then ran make -f Makefile.in TABLE to generate a new TABLE
erik> >erik> file containing my configuration among all other configs. Then I ran
erik> >erik> a normal Configure
erik> >erik>
erik> >erik> Doing that with pre3, make TABLE bombs out because the Makefile.in file
erik> >erik> has stuff in it that must be processed by perl first (line 33 is first case)
erik> >erik>
erik> >erik> How should I update the TABLE file in pre3 ?
erik> >
erik> >Some changes have been made, it's true.  Would you mind letting me
erik> >have a look at your .conf file to see for myself?
erik> >
erik> >--
erik> >Richard Levitte         [hidden email]
erik> >OpenSSL Project         http://www.openssl.org/~levitte/
erik> >--
erik> >openssl-dev mailing list
erik> >To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
erik>
--
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
Reply | Threaded
Open this post in threaded view
|

Re: 1.1-pre3 configuration changes

Erik Forsberg-11

>-- Original Message --
>
>In message <[hidden email]> on Mon, 15 Feb 2016 15:02:52 -0800, "Erik Forsberg" <[hidden email]> said:
>
>erik> Sure, attached.
>erik> However, dont think anything wrong with it, I did notice the changes
>erik> and aligned. The question is more how do I incorporate my custom conf file into
>erik> the build system. Copying this conf file into Configrations and running
>erik> make -f Makefile.in TABLE
>erik> results in this
>erik>
>erik> + cp ../20-efca.conf Configurations
>erik> + make -f Makefile.in TABLE
>erik> make: Fatal error in reader: Makefile.in, line 33: Badly formed macro assignment
>
>Ah-ha!  Using Makefile.in directly like that is not possible any
>more.  The reason is that we've templatised it.  If you look, you'll
>see that there are perl fragments within {- and -} delimiters.  Line
>33 is right in the middle of one of those.
>
>The answer is that you MUST configure first.  We could probably
>clarify that a bit louder (and when I'm looking in INSTALL right now,
>I'm noticing it's lagging behind on the changes.  To be fixed!)

That creates the illusion of a chicken and an egg paradox.
You cant configure your custom config until AFTER you have
managed to update the TABLE file. I guess you can configure
a standard target, then put in your custom conf file, then
run make TABLE, then re-configure the custom target. Will that
be the recommended process ?

>
>erik> GNU make throws a differently worded error on same line.
>
>Yup.  The answer will remain "don't do that, configure first!"
>
>erik> If I manually run
>erik> perl Configure TABLE > TABLE
>erik> it works OK, at least I can run Configure
>
>Yes.
>
>erik> Another bug is that with pre3, assembler support is broken for solaris64-x86_64-cc
>erik> configurations. First assembler file x86_64cpuid.pl gets tons of syntax errors.
>erik> Havent looked too deep yet. Has been working fine for ever.
>
>Ok, that's to look into.  Mind giving us a log?

will start a new thread on that.

>
>erik> My platform is Solaris 11 x64 using native SunStudio btw
>erik> Will try gcc too.
>erik>
>erik> >-- Original Message --
>erik> >
>erik> >In message <[hidden email]> on Mon, 15 Feb 2016 14:30:48 -0800, "Erik Forsberg" <[hidden email]> said:
>erik> >
>erik> >erik>
>erik> >erik> OK, now I'm confused, in pre2 I started using personal .conf
>erik> >erik> files with my specific build configuration, that no longer works in pre3
>erik> >erik>
>erik> >erik> If I do the same as before, I copied my conf file into Configurations
>erik> >erik> subdirectory then ran make -f Makefile.in TABLE to generate a new TABLE
>erik> >erik> file containing my configuration among all other configs. Then I ran
>erik> >erik> a normal Configure
>erik> >erik>
>erik> >erik> Doing that with pre3, make TABLE bombs out because the Makefile.in file
>erik> >erik> has stuff in it that must be processed by perl first (line 33 is first case)
>erik> >erik>
>erik> >erik> How should I update the TABLE file in pre3 ?
>erik> >
>erik> >Some changes have been made, it's true.  Would you mind letting me
>erik> >have a look at your .conf file to see for myself?
>erik> >
>erik> >--
>erik> >Richard Levitte         [hidden email]
>erik> >OpenSSL Project         http://www.openssl.org/~levitte/
>erik> >--
>erik> >openssl-dev mailing list
>erik> >To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
>erik>
>--
>openssl-dev mailing list
>To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev

--
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
Reply | Threaded
Open this post in threaded view
|

Re: 1.1-pre3 configuration changes

Richard Levitte - VMS Whacker-2
In message <[hidden email]> on Mon, 15 Feb 2016 15:40:40 -0800, "Erik Forsberg" <[hidden email]> said:

erik>
erik> >-- Original Message --
erik> >
erik> >In message <[hidden email]> on Mon, 15 Feb 2016 15:02:52 -0800, "Erik Forsberg" <[hidden email]> said:
erik> >
erik> >erik> Sure, attached.
erik> >erik> However, dont think anything wrong with it, I did notice the changes
erik> >erik> and aligned. The question is more how do I incorporate my custom conf file into
erik> >erik> the build system. Copying this conf file into Configrations and running
erik> >erik> make -f Makefile.in TABLE
erik> >erik> results in this
erik> >erik>
erik> >erik> + cp ../20-efca.conf Configurations
erik> >erik> + make -f Makefile.in TABLE
erik> >erik> make: Fatal error in reader: Makefile.in, line 33: Badly formed macro assignment
erik> >
erik> >Ah-ha!  Using Makefile.in directly like that is not possible any
erik> >more.  The reason is that we've templatised it.  If you look, you'll
erik> >see that there are perl fragments within {- and -} delimiters.  Line
erik> >33 is right in the middle of one of those.
erik> >
erik> >The answer is that you MUST configure first.  We could probably
erik> >clarify that a bit louder (and when I'm looking in INSTALL right now,
erik> >I'm noticing it's lagging behind on the changes.  To be fixed!)
erik>
erik> That creates the illusion of a chicken and an egg paradox.
erik> You cant configure your custom config until AFTER you have
erik> managed to update the TABLE file.

That's not at all true.  The TABLE file is for your convenience only,
meant as a visual configuration debugging tool which has frankly lost
its value by now.  It was much more valuable in pre-1.1 OpenSSL
versions, as those string configurations are quite hard to read.
Setting up and building OpenSSL doesn't need the TABLE file at all.  I
can't remember that it ever has.

All you have to do to configure your favorit configuration is this:

    perl Configure efca-x64-gcc [options]

That's it.  No TABLE file needed.

erik> I guess you can configure a standard target, then put in your
erik> custom conf file, then run make TABLE, then re-configure the
erik> custom target. Will that be the recommended process ?

Nope.  Just put your custom 20-efca.conf in Configurations and fire
off the Configure command demonstrated above.  I'm afraid you're
complicating things needlessly...

erik>
erik> >
erik> >erik> GNU make throws a differently worded error on same line.
erik> >
erik> >Yup.  The answer will remain "don't do that, configure first!"
erik> >
erik> >erik> If I manually run
erik> >erik> perl Configure TABLE > TABLE
erik> >erik> it works OK, at least I can run Configure
erik> >
erik> >Yes.
erik> >
erik> >erik> Another bug is that with pre3, assembler support is broken for solaris64-x86_64-cc
erik> >erik> configurations. First assembler file x86_64cpuid.pl gets tons of syntax errors.
erik> >erik> Havent looked too deep yet. Has been working fine for ever.
erik> >
erik> >Ok, that's to look into.  Mind giving us a log?
erik>
erik> will start a new thread on that.
erik>
erik> >
erik> >erik> My platform is Solaris 11 x64 using native SunStudio btw
erik> >erik> Will try gcc too.
erik> >erik>
erik> >erik> >-- Original Message --
erik> >erik> >
erik> >erik> >In message <[hidden email]> on Mon, 15 Feb 2016 14:30:48 -0800, "Erik Forsberg" <[hidden email]> said:
erik> >erik> >
erik> >erik> >erik>
erik> >erik> >erik> OK, now I'm confused, in pre2 I started using personal .conf
erik> >erik> >erik> files with my specific build configuration, that no longer works in pre3
erik> >erik> >erik>
erik> >erik> >erik> If I do the same as before, I copied my conf file into Configurations
erik> >erik> >erik> subdirectory then ran make -f Makefile.in TABLE to generate a new TABLE
erik> >erik> >erik> file containing my configuration among all other configs. Then I ran
erik> >erik> >erik> a normal Configure
erik> >erik> >erik>
erik> >erik> >erik> Doing that with pre3, make TABLE bombs out because the Makefile.in file
erik> >erik> >erik> has stuff in it that must be processed by perl first (line 33 is first case)
erik> >erik> >erik>
erik> >erik> >erik> How should I update the TABLE file in pre3 ?
erik> >erik> >
erik> >erik> >Some changes have been made, it's true.  Would you mind letting me
erik> >erik> >have a look at your .conf file to see for myself?
erik> >erik> >
erik> >erik> >--
erik> >erik> >Richard Levitte         [hidden email]
erik> >erik> >OpenSSL Project         http://www.openssl.org/~levitte/
erik> >erik> >--
erik> >erik> >openssl-dev mailing list
erik> >erik> >To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
erik> >erik>
erik> >--
erik> >openssl-dev mailing list
erik> >To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
erik>
erik> --
erik> openssl-dev mailing list
erik> To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
erik>
--
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
Reply | Threaded
Open this post in threaded view
|

Re: 1.1-pre3 configuration changes

Erik Forsberg-11

>-- Original Message --
>
>In message <[hidden email]> on Mon, 15 Feb 2016 15:40:40 -0800, "Erik Forsberg" <[hidden email]> said:
>
>erik>
>erik> >-- Original Message --
>erik> >
>erik> >In message <[hidden email]> on Mon, 15 Feb 2016 15:02:52 -0800, "Erik Forsberg" <[hidden email]> said:
>erik> >
>erik> >erik> Sure, attached.
>erik> >erik> However, dont think anything wrong with it, I did notice the changes
>erik> >erik> and aligned. The question is more how do I incorporate my custom conf file into
>erik> >erik> the build system. Copying this conf file into Configrations and running
>erik> >erik> make -f Makefile.in TABLE
>erik> >erik> results in this
>erik> >erik>
>erik> >erik> + cp ../20-efca.conf Configurations
>erik> >erik> + make -f Makefile.in TABLE
>erik> >erik> make: Fatal error in reader: Makefile.in, line 33: Badly formed macro assignment
>erik> >
>erik> >Ah-ha!  Using Makefile.in directly like that is not possible any
>erik> >more.  The reason is that we've templatised it.  If you look, you'll
>erik> >see that there are perl fragments within {- and -} delimiters.  Line
>erik> >33 is right in the middle of one of those.
>erik> >
>erik> >The answer is that you MUST configure first.  We could probably
>erik> >clarify that a bit louder (and when I'm looking in INSTALL right now,
>erik> >I'm noticing it's lagging behind on the changes.  To be fixed!)
>erik>
>erik> That creates the illusion of a chicken and an egg paradox.
>erik> You cant configure your custom config until AFTER you have
>erik> managed to update the TABLE file.
>
>That's not at all true.  The TABLE file is for your convenience only,
>meant as a visual configuration debugging tool which has frankly lost
>its value by now.  It was much more valuable in pre-1.1 OpenSSL
>versions, as those string configurations are quite hard to read.
>Setting up and building OpenSSL doesn't need the TABLE file at all.  I
>can't remember that it ever has.

    I certainly was under the impression it was needed.
    Every .conf file had an admonition to update TABLE at the top -:)
    A quick test confirms that you dont need it anymore though.
    Which is fine with me.

>
>All you have to do to configure your favorit configuration is this:
>
>    perl Configure efca-x64-gcc [options]
>
>That's it.  No TABLE file needed.
>
>erik> I guess you can configure a standard target, then put in your
>erik> custom conf file, then run make TABLE, then re-configure the
>erik> custom target. Will that be the recommended process ?
>
>Nope.  Just put your custom 20-efca.conf in Configurations and fire
>off the Configure command demonstrated above.  I'm afraid you're
>complicating things needlessly...

   Indeed looks like it. This process of custom configs works perfectly
   fine by me.

>
>erik>
>erik> >
>erik> >erik> GNU make throws a differently worded error on same line.
>erik> >
>erik> >Yup.  The answer will remain "don't do that, configure first!"
>erik> >
>erik> >erik> If I manually run
>erik> >erik> perl Configure TABLE > TABLE
>erik> >erik> it works OK, at least I can run Configure
>erik> >
>erik> >Yes.
>erik> >
>erik> >erik> Another bug is that with pre3, assembler support is broken for solaris64-x86_64-cc
>erik> >erik> configurations. First assembler file x86_64cpuid.pl gets tons of syntax errors.
>erik> >erik> Havent looked too deep yet. Has been working fine for ever.
>erik> >
>erik> >Ok, that's to look into.  Mind giving us a log?
>erik>
>erik> will start a new thread on that.
>erik>
>erik> >
>erik> >erik> My platform is Solaris 11 x64 using native SunStudio btw
>erik> >erik> Will try gcc too.
>erik> >erik>
>erik> >erik> >-- Original Message --
>erik> >erik> >
>erik> >erik> >In message <[hidden email]> on Mon, 15 Feb 2016 14:30:48 -0800, "Erik Forsberg" <[hidden email]> said:
>erik> >erik> >
>erik> >erik> >erik>
>erik> >erik> >erik> OK, now I'm confused, in pre2 I started using personal .conf
>erik> >erik> >erik> files with my specific build configuration, that no longer works in pre3
>erik> >erik> >erik>
>erik> >erik> >erik> If I do the same as before, I copied my conf file into Configurations
>erik> >erik> >erik> subdirectory then ran make -f Makefile.in TABLE to generate a new TABLE
>erik> >erik> >erik> file containing my configuration among all other configs. Then I ran
>erik> >erik> >erik> a normal Configure
>erik> >erik> >erik>
>erik> >erik> >erik> Doing that with pre3, make TABLE bombs out because the Makefile.in file
>erik> >erik> >erik> has stuff in it that must be processed by perl first (line 33 is first case)
>erik> >erik> >erik>
>erik> >erik> >erik> How should I update the TABLE file in pre3 ?
>erik> >erik> >
>erik> >erik> >Some changes have been made, it's true.  Would you mind letting me
>erik> >erik> >have a look at your .conf file to see for myself?
>erik> >erik> >
>erik> >erik> >--
>erik> >erik> >Richard Levitte         [hidden email]
>erik> >erik> >OpenSSL Project         http://www.openssl.org/~levitte/
>erik> >erik> >--
>erik> >erik> >openssl-dev mailing list
>erik> >erik> >To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
>erik> >erik>
>erik> >--
>erik> >openssl-dev mailing list
>erik> >To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
>erik>
>erik> --
>erik> openssl-dev mailing list
>erik> To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
>erik>
>--
>openssl-dev mailing list
>To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev

--
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
Reply | Threaded
Open this post in threaded view
|

Re: 1.1-pre3 configuration changes

Richard Levitte - VMS Whacker-2
In message <[hidden email]> on Mon, 15 Feb 2016 16:06:20 -0800, "Erik Forsberg" <[hidden email]> said:

erik>     I certainly was under the impression it was needed.
erik>     Every .conf file had an admonition to update TABLE at the top -:)
erik>     A quick test confirms that you dont need it anymore though.
erik>     Which is fine with me.

Some of them still do...  *ahem* a gross exageration, glad we could
clear that up.

erik> >Nope.  Just put your custom 20-efca.conf in Configurations and fire
erik> >off the Configure command demonstrated above.  I'm afraid you're
erik> >complicating things needlessly...
erik>
erik>    Indeed looks like it. This process of custom configs works perfectly
erik>    fine by me.

Yeah, we're a bit fond of them too.

erik>
erik> >
erik> >erik>
erik> >erik> >
erik> >erik> >erik> GNU make throws a differently worded error on same line.
erik> >erik> >
erik> >erik> >Yup.  The answer will remain "don't do that, configure first!"
erik> >erik> >
erik> >erik> >erik> If I manually run
erik> >erik> >erik> perl Configure TABLE > TABLE
erik> >erik> >erik> it works OK, at least I can run Configure
erik> >erik> >
erik> >erik> >Yes.
erik> >erik> >
erik> >erik> >erik> Another bug is that with pre3, assembler support is broken for solaris64-x86_64-cc
erik> >erik> >erik> configurations. First assembler file x86_64cpuid.pl gets tons of syntax errors.
erik> >erik> >erik> Havent looked too deep yet. Has been working fine for ever.
erik> >erik> >
erik> >erik> >Ok, that's to look into.  Mind giving us a log?
erik> >erik>
erik> >erik> will start a new thread on that.
erik> >erik>
erik> >erik> >
erik> >erik> >erik> My platform is Solaris 11 x64 using native SunStudio btw
erik> >erik> >erik> Will try gcc too.
erik> >erik> >erik>
erik> >erik> >erik> >-- Original Message --
erik> >erik> >erik> >
erik> >erik> >erik> >In message <[hidden email]> on Mon, 15 Feb 2016 14:30:48 -0800, "Erik Forsberg" <[hidden email]> said:
erik> >erik> >erik> >
erik> >erik> >erik> >erik>
erik> >erik> >erik> >erik> OK, now I'm confused, in pre2 I started using personal .conf
erik> >erik> >erik> >erik> files with my specific build configuration, that no longer works in pre3
erik> >erik> >erik> >erik>
erik> >erik> >erik> >erik> If I do the same as before, I copied my conf file into Configurations
erik> >erik> >erik> >erik> subdirectory then ran make -f Makefile.in TABLE to generate a new TABLE
erik> >erik> >erik> >erik> file containing my configuration among all other configs. Then I ran
erik> >erik> >erik> >erik> a normal Configure
erik> >erik> >erik> >erik>
erik> >erik> >erik> >erik> Doing that with pre3, make TABLE bombs out because the Makefile.in file
erik> >erik> >erik> >erik> has stuff in it that must be processed by perl first (line 33 is first case)
erik> >erik> >erik> >erik>
erik> >erik> >erik> >erik> How should I update the TABLE file in pre3 ?
erik> >erik> >erik> >
erik> >erik> >erik> >Some changes have been made, it's true.  Would you mind letting me
erik> >erik> >erik> >have a look at your .conf file to see for myself?
erik> >erik> >erik> >
erik> >erik> >erik> >--
erik> >erik> >erik> >Richard Levitte         [hidden email]
erik> >erik> >erik> >OpenSSL Project         http://www.openssl.org/~levitte/
erik> >erik> >erik> >--
erik> >erik> >erik> >openssl-dev mailing list
erik> >erik> >erik> >To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
erik> >erik> >erik>
erik> >erik> >--
erik> >erik> >openssl-dev mailing list
erik> >erik> >To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
erik> >erik>
erik> >erik> --
erik> >erik> openssl-dev mailing list
erik> >erik> To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
erik> >erik>
erik> >--
erik> >openssl-dev mailing list
erik> >To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
erik>
erik> --
erik> openssl-dev mailing list
erik> To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev
erik>
--
openssl-dev mailing list
To unsubscribe: https://mta.openssl.org/mailman/listinfo/openssl-dev